Bug 1273907 - tooltips in webadmin shouldn't have fixed width
tooltips in webadmin shouldn't have fixed width
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Greg Sheremeta
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 09:24 EDT by movciari
Modified: 2016-03-16 15:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-16 15:38:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ecohen: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description movciari 2015-10-21 09:24:07 EDT
Description of problem:
New tooltips in RHEVM-3.6 have fixed width.
This is a problem when you want to see some tooltip with long text in it - since it's very narrow, it has to be very high - often so high it doesn't fit inside the browser window on fullHD display.
In case there's too much content in tooltip, its width should be dynamically changed in order to achieve reasonable height.
If we can't fit all the text inside the tooltip of reasonable size, it should display the beginning and end of text, omitting some part in the middle - unlike current implementation of tooltips, which only allows you to see the bottom of tooltip, because top part doesn't fit inside the screen

Version-Release number of selected component (if applicable):
3.6.0-0.18.el6

How reproducible:
always

Steps to Reproduce:
1. Make installation of a host fail because of missing rpm dependencies
2. Go to events tab, or host's event subtab
3. Find line that says: Failed to install Host host1 Failed to execute stage 'Package installation': [u'Errors were encountered while downloading...
4. Leave your cursor on that line to see the tooltip

Actual results:
Tooltip doesn't fit inside the screen

Expected results:
Tooltip should always fit inside the screen

Additional info:
There are probably some other tooltips that don't fit the screen
Comment 1 Einav Cohen 2015-10-22 08:24:51 EDT
*** Bug 1235784 has been marked as a duplicate of this bug. ***
Comment 2 vszocs 2015-10-23 12:11:19 EDT
One solution is to use fixed CSS max-width - limit tooltip's horizontal size and allow the vertical size to grow.
Comment 3 Greg Sheremeta 2016-03-16 15:38:09 EDT
Tooltips have a fixed with by design (part of PatternFly).

If there are specific places they need to be widened, please open bugs on those. We can widen something up to 620px if needed. If that's not enough, I have to question whether the value belongs in a tooltip.

Note You need to log in before you can comment on or make changes to this bug.