Bug 1273910 - RFE: add timeout option for virConnectOpen
Summary: RFE: add timeout option for virConnectOpen
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-21 13:27 UTC by Fl@sh
Modified: 2019-04-01 09:47 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-01 09:47:33 UTC


Attachments (Terms of Use)

Description Fl@sh 2015-10-21 13:27:00 UTC
Description of problem:
add this argument to make the connection more controllable


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
for example:
virConnectOpenAuth(const char *name,
                   virConnectAuthPtr auth,
                   unsigned int flags,
                   unsigned long timeout)

Additional info:

Comment 1 Cole Robinson 2015-10-21 14:15:00 UTC
We couldn't add it to the existing API since libvirt doesn't break API. We would need to add some separate way to set a timeout.

Comment 2 Fl@sh 2015-10-21 14:58:33 UTC
I looked at the code and found that the addition of an argument will entail numerous changes. I hope that the addition of an option will not take long.

Comment 3 Cole Robinson 2015-10-21 16:17:49 UTC
it's actually more likely that this bug will just sit here indefinitely. filing an RFE doesn't give any guarantee that it will ever be implemented...


Note You need to log in before you can comment on or make changes to this bug.