Bug 1273912 - The samba-common package is required by other samba sub-packages only for pre scripts
Summary: The samba-common package is required by other samba sub-packages only for pre...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-21 13:35 UTC by Patrik Kis
Modified: 2015-11-19 09:11 UTC (History)
5 users (show)

Fixed In Version: samba-4.2.3-9.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 09:11:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2258 normal SHIPPED_LIVE samba bug fix and enhancement update 2015-11-19 09:22:47 UTC

Description Patrik Kis 2015-10-21 13:35:01 UTC
Description of problem:
For example, the new samba-common-tools sub-package that indirectly depends on samba-common, will pull samba-common when it is installed, but then samba common can be erased without erasing any other samba sub-package. This can lead to situation when net join is not working.
The problem seems to be in this line is the spec file:
Requires(pre): %{name}-common = %{samba_depver}

Version-Release number of selected component (if applicable):
samba-4.2.3-7.el7

How reproducible:
always

Steps to Reproduce:

# rm -rf /var/lib/samba/ && yum erase -y `rpm -qa libsmb\* samba\*`
...snip

# yum install -y samba-common-tools
... snip

# rpm -ev samba-common
Preparing packages...
samba-common-0:4.2.3-7.el7.noarch
#
# echo password | /usr/bin/net -s realmd-smb-conf -U administrator ads join ad.domain.test; echo $?
Enter administrator's password:
Failed to open /var/lib/samba/private/secrets.tdb
Failed to join domain: Unable to open secrets database
255

Comment 7 errata-xmlrpc 2015-11-19 09:11:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2258.html


Note You need to log in before you can comment on or make changes to this bug.