Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1273924 - realmd proposes wrong package to install
Summary: realmd proposes wrong package to install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: realmd
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Sumit Bose
QA Contact: Marek Marusic
URL:
Whiteboard:
: 1274251 (view as bug list)
Depends On:
Blocks: 1313485 1296125
TreeView+ depends on / blocked
 
Reported: 2015-10-21 13:51 UTC by Patrik Kis
Modified: 2016-11-04 07:46 UTC (History)
4 users (show)

Fixed In Version: realmd-0.16.1-6.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:46:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2511 normal SHIPPED_LIVE realmd bug fix and enhancement update 2016-11-03 14:14:00 UTC

Description Patrik Kis 2015-10-21 13:51:02 UTC
Description of problem:
After the recent samba update the net tools moved from samba-common to samba-common-tools package. But realm still proposes to install the package-samba common. It looks like as it was hardcoded.

Version-Release number of selected component (if applicable):
realmd-0.16.1-5.el7
samba-4.2.3-7.el7

How reproducible:
always

Steps to Reproduce:

# rpm -e samba-client-common
#
# rpm -q oddjob oddjob-mkhomedir sssd samba-common
oddjob-0.31.5-4.el7.x86_64
oddjob-mkhomedir-0.31.5-4.el7.x86_64
sssd-1.13.0-40.el7.x86_64
samba-common-4.2.3-7.el7.noarch
#
# echo password | realm join --user=administrator --membership-software=samba ad.test.com
Password for administrator: 
See: journalctl REALMD_OPERATION=r11173.1786
realm: Couldn't join realm: Necessary packages are not installed: oddjob, oddjob-mkhomedir, sssd, samba-common
#

Comment 2 Jan Pazdziora 2015-10-22 12:33:21 UTC
*** Bug 1274251 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2016-11-04 07:46:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2511.html


Note You need to log in before you can comment on or make changes to this bug.