Bug 1273941 - [webadmin] Storage Domain Custom connection parameters should editable when domain is in maintenance/detached
[webadmin] Storage Domain Custom connection parameters should editable when d...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Tal Nisan
Natalie Gavrielov
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 10:32 EDT by Gonza
Modified: 2016-02-18 06:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:00:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Gonza 2015-10-21 10:32:23 EDT
Description of problem:
After detaching a Storage Domain for edit, Custom connection parameters fields should be disabled for input

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.18.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Click on Edit button for an unattached SD
2. Modify any of the Custom connection parameters
3. Click OK

Actual results:
Operation Canceled window pops up with message:
    Error while executing action: Cannot edit Storage. Can only update the following fields: name, description, comment, wipe after delete, low space threshold, and critical space threshold.

Expected results:
Custom connection parameters should be disabled for editing
Comment 1 Allon Mureinik 2015-10-26 09:25:35 EDT
Au contraire - if the path is editable, so should the custom connection params.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-26 15:06:29 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Yaniv Lavi 2015-10-29 08:49:40 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 4 Allon Mureinik 2015-11-09 08:55:11 EST
The move to 4.0 was due to a miscommunication between Yaniv and I (specifically, I suspect this is a regression).

Resetting target milestone to 3.6.1, and we can discuss in the next scrub meeting.
Comment 5 Red Hat Bugzilla Rules Engine 2015-11-16 07:44:17 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 6 Tal Nisan 2015-12-24 10:09:30 EST
Could not reproduce, when the domain is detached or in maintenance mode both the path and the custom properties are editable.
As for the actual results described in the bug:
"Operation Canceled window pops up with message:
    Error while executing action: Cannot edit Storage. Can only update the following fields: name, description, comment, wipe after delete, low space threshold, and critical space threshold."

This message is a result of the storage properties update command rather than the connection properties update command which means that storage domain fields other than those listed were changed, this is regardless to the changes in the connection (custom properties, path)
Comment 7 Red Hat Bugzilla Rules Engine 2015-12-24 10:09:34 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 8 Natalie Gavrielov 2016-01-05 07:54:03 EST
Scenario tested:

Ran the following scenario twice: first for a detached storage domain and second time for "in maintenance" storage domain:

1. Edit storage domain.
2. Modify any of the values (custom connection params, advanced params, comment, description, export path).
3. Click Ok.

Result:

No errors in UI / engine.log.
Editing operation passes successfully.

Verified using rhevm-3.6.2-0.1.el6.noarch (build 3.6.2-3)

Note You need to log in before you can comment on or make changes to this bug.