Bug 1273965 - libvirt error since managed non pluggable device was removed unexpectedly
libvirt error since managed non pluggable device was removed unexpectedly
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Console-Integration (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Francesco Romani
Israel Pinto
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 11:25 EDT by Israel Pinto
Modified: 2016-02-18 06:05 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:05:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: planning_ack+
michal.skrivanek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
start_vm_log_engine_and_vdsm (251.90 KB, application/zip)
2015-10-21 11:35 EDT, Israel Pinto
no flags Details
migrate_vm_Jenkins_run_vdsm_log (330.22 KB, application/x-bzip)
2015-10-21 11:40 EDT, Israel Pinto
no flags Details
migrate_vm_Jenkins_run_engine_log (72.24 KB, application/zip)
2015-10-21 11:42 EDT, Israel Pinto
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50307 master MERGED core: device: avoid warning about Graphics device 2015-12-20 03:12 EST
oVirt gerrit 51707 ovirt-engine-3.6 MERGED core: device: avoid warning about Graphics device 2016-01-12 09:32 EST

  None (edit)
Description Israel Pinto 2015-10-21 11:25:38 EDT
Description of problem:
Error on engine while stating VM, and after VM migration
From engine log:
[root@jenkins-vm-02 ovirt-engine]# tail -f engine.log | grep 'managed non pluggable device was removed unexpectedly from libvirt'
2015-10-21 17:08:09,755 ERROR [org.ovirt.engine.core.vdsbroker.VmsMonitoring] (ForkJoinPool-1-worker-296) [31c677c3] VM '6e7e9891-79ed-4b8c-8dce-0e0d67db9358' managed non pluggable device was removed unexpectedly from libvirt: 'VmDevice:{id='VmDeviceId:{deviceId='304b5d9a-7099-406e-9365-06a94ab948ba', vmId='6e7e9891-79ed-4b8c-8dce-0e0d67db9358'}', device='spice', type='GRAPHICS', bootOrder='0', specParams='[]', address='', managed='true', plugged='false', readOnly='false', deviceAlias='', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}'
2015-10-21 17:08:42,858 ERROR [org.ovirt.engine.core.vdsbroker.VmsMonitoring] (DefaultQuartzScheduler_Worker-96) [31c837eb] VM '6e7e9891-79ed-4b8c-8dce-0e0d67db9358' managed non pluggable device was removed unexpectedly from libvirt: 'VmDevice:{id='VmDeviceId:{deviceId='304b5d9a-7099-406e-9365-06a94ab948ba', vmId='6e7e9891-79ed-4b8c-8dce-0e0d67db9358'}', device='spice', type='GRAPHICS', bootOrder='0', specParams='[]', address='', managed='true', plugged='false', readOnly='false', deviceAlias='', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}'

Version-Release number of selected component (if applicable):
RHEVM Version: 3.6.0.1-0.1.el6 
vdsm: vdsm-4.17.9-1.el7ev
libvirt:vdsm-4.17.9-1.el7ev

How reproducible:
All the time. After start VM and after migration finished

Additional info:
We can see in vsdm that device is on the all VM list.
deviceId: 304b5d9a-7099-406e-9365-06a94ab948ba

VM lists:

Thread-138462::DEBUG::2015-10-21 17:08:42,855::__init__::533::jsonrpc.JsonRpcServer::(_serveRequest) Return 'Host.getVMFullList' in bridge with [{u'acpiEnable': u'true', u'emulatedMachine': u'pc-i440fx-rhel7.2.0', u'vmId': u'6e7e9891-79ed-4b8c-8dce-0e0d67db9358', u'memGuaranteedSize': 1024, u'transparentHugePages': u'true', 'displaySecurePort': u'5901', u'spiceSslCipherSuite': u'DEFAULT', u'cpuType': u'Conroe', u'smp': u'1', 'pauseCode': 'NOERR', u'guestNumaNodes': [{u'nodeIndex': 0, u'cpus': u'0', u'memory': u'1024'}], u'smartcardEnable': u'false', u'numaTune': {u'nodeset': u'0', u'mode': u'interleave'}, u'custom': {u'device_bec03410-439c-4ab2-88e8-e65f300687e0': u"VmDevice:{id='VmDeviceId:{deviceId='bec03410-439c-4ab2-88e8-e65f300687e0', vmId='6e7e9891-79ed-4b8c-8dce-0e0d67db9358'}', device='unix', type='CHANNEL', bootOrder='0', specParams='[]', address='{bus=0, controller=0, type=virtio-serial, port=1}', managed='false', plugged='true', readOnly='false', deviceAlias='channel0', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}", u'device_bec03410-439c-4ab2-88e8-e65f300687e0device_92c49f46-92a0-459a-80d2-f89791abcfe5device_18843327-f3ac-46f8-8522-c622eb3c1106': u"VmDevice:{id='VmDeviceId:{deviceId='18843327-f3ac-46f8-8522-c622eb3c1106', vmId='6e7e9891-79ed-4b8c-8dce-0e0d67db9358'}', device='spicevmc', type='CHANNEL', bootOrder='0', specParams='[]', address='{bus=0, controller=0, type=virtio-serial, port=3}', managed='false', plugged='true', readOnly='false', deviceAlias='channel2', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}", u'device_bec03410-439c-4ab2-88e8-e65f300687e0device_92c49f46-92a0-459a-80d2-f89791abcfe5device_18843327-f3ac-46f8-8522-c622eb3c1106device_f08c29ce-9f02-4df0-903f-03ca653fbfae': u"VmDevice:{id='VmDeviceId:{deviceId='f08c29ce-9f02-4df0-903f-03ca653fbfae', vmId='6e7e9891-79ed-4b8c-8dce-0e0d67db9358'}', device='ide', type='CONTROLLER', bootOrder='0', specParams='[]', address='{slot=0x01, bus=0x00, domain=0x0000, type=pci, function=0x1}', managed='false', plugged='true', readOnly='false', deviceAlias='ide', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}", u'device_bec03410-439c-4ab2-88e8-e65f300687e0device_92c49f46-92a0-459a-80d2-f89791abcfe5': u"VmDevice:{id='VmDeviceId:{deviceId='92c49f46-92a0-459a-80d2-f89791abcfe5', vmId='6e7e9891-79ed-4b8c-8dce-0e0d67db9358'}', device='unix', type='CHANNEL', bootOrder='0', specParams='[]', address='{bus=0, controller=0, type=virtio-serial, port=2}', managed='false', plugged='true', readOnly='false', deviceAlias='channel1', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}"}, u'vmType': u'kvm', u'memSize': 1024, u'smpCoresPerSocket': u'1', u'vmName': u'golden_env_mixed_virtio_0', u'nice': u'0', 'status': 'Up', u'maxMemSize': 4194304, u'bootMenuEnable': u'false', 'pid': '8275', u'copyPasteEnable': u'true', 'displayIp': '10.35.161.150', 'displayPort': u'5900', 'guestDiskMapping': {u'e63f093d-c4b3-4322-b': {u'name': u'/dev/vda'}, u'QEMU_DVD-ROM_': {u'name': u'/dev/sr0'}}, u'spiceSecureChannels': u'smain,sinputs,scursor,splayback,srecord,sdisplay,susbredir,ssmartcard', u'fileTransferEnable': u'true', 'nicModel': 'rtl8139,pv', u'keyboardLayout': u'en-us', u'kvmEnable': u'true', u'displayNetwork': u'ovirtmgmt', u'devices': [{u'specParams': {}, 'alias': u'sound0', 'deviceType': u'sound', u'deviceId': u'f97e107c-9549-4631-ac28-145a6b37a1df', u'address': {u'slot': u'0x04', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}, u'device': u'ich6', u'type': u'sound'}, {'device': 'memballoon', 'specParams': {'model': 'none'}, 'deviceType': 'balloon', 'type': 'balloon', 'alias': u'balloon0'}, {u'specParams': {}, 'alias': u'virtio-serial0', 'deviceType': u'controller', u'deviceId': u'cc8cd52b-5d0d-437b-894b-b92c19cff932', u'address': {u'slot': u'0x05', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}, u'device': u'virtio-serial', u'type': u'controller'}, {u'specParams': {u'vram': u'32768', u'heads': u'1'}, 'alias': u'video0', 'deviceType': u'video', u'deviceId': u'fdb40a91-f2d5-45f2-9c14-88604d1d4b71', u'address': {u'slot': u'0x02', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}, u'device': u'qxl', u'type': u'video'}, {'tlsPort': u'5901', u'specParams': {u'fileTransferEnable': u'true', u'copyPasteEnable': u'true', 'displayIp': '10.35.161.150', 'displayNetwork': u'ovirtmgmt'}, 'deviceType': u'graphics', u'deviceId': u'304b5d9a-7099-406e-9365-06a94ab948ba', u'device': u'spice', u'type': u'graphics', 'port': u'5900'}, {u'nicModel': u'pv', u'macAddr': u'00:1a:4a:16:81:ca', u'linkActive': True, u'network': u'ovirtmgmt', u'specParams': {u'inbound': {}, u'outbound': {}}, u'filter': u'vdsm-no-mac-spoofing', 'alias': u'net0', 'deviceType': u'interface', u'deviceId': u'f9b1fc56-1e35-4e6c-89f3-f1eb30bb8fc2', u'address': {u'slot': u'0x03', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}, u'device': u'bridge', u'type': u'interface', 'name': u'vnet0'}, {u'index': u'2', u'iface': u'ide', 'name': u'hdc', 'alias': u'ide0-1-0', u'specParams': {u'path': u''}, u'readonly': 'True', 'deviceType': u'disk', u'deviceId': u'228f2513-5196-4fff-bf71-1ab88f015cac', u'address': {u'bus': u'1', u'controller': u'0', u'type': u'drive', u'target': u'0', u'unit': u'0'}, u'device': u'cdrom', u'shared': u'false', u'path': '', u'type': u'disk'}, {u'poolID': u'ebe1eba1-681e-4562-84f9-c8324988bcdc', 'reqsize': '0', 'index': '0', u'iface': u'virtio', 'apparentsize': '93257728', u'specParams': {}, u'imageID': u'e63f093d-c4b3-4322-be0e-05420ae05a12', u'readonly': 'False', 'deviceType': u'disk', u'shared': u'false', 'truesize': '93257728', u'type': u'disk', u'domainID': u'e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b', 'volumeInfo': {'domainID': u'e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b', 'volType': 'path', 'leaseOffset': 0, 'volumeID': u'be57b6b5-8d0f-4377-84e7-9d6c3e0e3fc9', 'leasePath': u'/rhev/data-center/mnt/10.35.160.108:_Virt_compute__ge__1__nfs__0/e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b/images/e63f093d-c4b3-4322-be0e-05420ae05a12/be57b6b5-8d0f-4377-84e7-9d6c3e0e3fc9.lease', 'imageID': u'e63f093d-c4b3-4322-be0e-05420ae05a12', 'path': u'/rhev/data-center/mnt/10.35.160.108:_Virt_compute__ge__1__nfs__0/e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b/images/e63f093d-c4b3-4322-be0e-05420ae05a12/be57b6b5-8d0f-4377-84e7-9d6c3e0e3fc9'}, u'format': u'cow', u'deviceId': u'e63f093d-c4b3-4322-be0e-05420ae05a12', u'address': {u'slot': u'0x06', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}, u'device': u'disk', 'path': u'/rhev/data-center/ebe1eba1-681e-4562-84f9-c8324988bcdc/e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b/images/e63f093d-c4b3-4322-be0e-05420ae05a12/be57b6b5-8d0f-4377-84e7-9d6c3e0e3fc9', u'propagateErrors': u'off', u'optional': u'false', 'name': u'vda', u'volumeID': u'be57b6b5-8d0f-4377-84e7-9d6c3e0e3fc9', 'alias': u'virtio-disk0', 'volumeChain': [{'domainID': u'e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b', 'volType': 'path', 'leaseOffset': 0, 'volumeID': u'5e0ba8a7-cabf-482e-9043-804c94a44faa', 'leasePath': u'/rhev/data-center/mnt/10.35.160.108:_Virt_compute__ge__1__nfs__0/e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b/images/e63f093d-c4b3-4322-be0e-05420ae05a12/5e0ba8a7-cabf-482e-9043-804c94a44faa.lease', 'imageID': u'e63f093d-c4b3-4322-be0e-05420ae05a12', 'path': u'/rhev/data-center/mnt/10.35.160.108:_Virt_compute__ge__1__nfs__0/e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b/images/e63f093d-c4b3-4322-be0e-05420ae05a12/5e0ba8a7-cabf-482e-9043-804c94a44faa'}, {'domainID': u'e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b', 'volType': 'path', 'leaseOffset': 0, 'volumeID': u'be57b6b5-8d0f-4377-84e7-9d6c3e0e3fc9', 'leasePath': u'/rhev/data-center/mnt/10.35.160.108:_Virt_compute__ge__1__nfs__0/e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b/images/e63f093d-c4b3-4322-be0e-05420ae05a12/be57b6b5-8d0f-4377-84e7-9d6c3e0e3fc9.lease', 'imageID': u'e63f093d-c4b3-4322-be0e-05420ae05a12', 'path': u'/rhev/data-center/mnt/10.35.160.108:_Virt_compute__ge__1__nfs__0/e6dc22c9-e7de-4cc4-91b4-e51a6b7eac9b/images/e63f093d-c4b3-4322-be0e-05420ae05a12/be57b6b5-8d0f-4377-84e7-9d6c3e0e3fc9'}]}, {'device': u'usb', 'alias': u'usb', 'deviceType': 'controller', 'type': 'controller', 'address': {u'slot': u'0x01', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x2'}}, {'device': u'ide', 'alias': u'ide', 'deviceType': 'controller', 'type': 'controller', 'address': {u'slot': u'0x01', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x1'}}, {'device': u'unix', 'alias': u'channel0', 'deviceType': u'channel', 'type': u'channel', 'address': {u'bus': u'0', u'controller': u'0', u'type': u'virtio-serial', u'port': u'1'}}, {'device': u'unix', 'alias': u'channel1', 'deviceType': u'channel', 'type': u'channel', 'address': {u'bus': u'0', u'controller': u'0', u'type': u'virtio-serial', u'port': u'2'}}, {'device': u'spicevmc', 'alias': u'channel2', 'deviceType': u'channel', 'type': u'channel', 'address': {u'bus': u'0', u'controller': u'0', u'type': u'virtio-serial', u'port': u'3'}}], u'display': 'qxl', u'timeOffset': u'0', u'maxVCpus': u'16', 'clientIp': '', 'statusTime': '4838758540', u'maxMemSlots': 16}]
Comment 1 Israel Pinto 2015-10-21 11:35 EDT
Created attachment 1085205 [details]
start_vm_log_engine_and_vdsm
Comment 2 Israel Pinto 2015-10-21 11:40 EDT
Created attachment 1085206 [details]
migrate_vm_Jenkins_run_vdsm_log
Comment 3 Israel Pinto 2015-10-21 11:42 EDT
Created attachment 1085207 [details]
migrate_vm_Jenkins_run_engine_log
Comment 8 Michal Skrivanek 2015-12-04 09:43:21 EST
any thoughts?
Comment 9 Francesco Romani 2015-12-04 10:03:10 EST
Last time I checked, a few months ago, graphics device didn't have addresses.
This was, at the time, on purpose, because they represent domain-configurables modeled as device, but they are not exposed as guest. Video devices are.

In other words, the guest does not care how we connect to it, maybe through spice, maybe through vnc, it just renders using the video and sound devices.

Will check if/how this changed in libvirt.
Meantime: besides scary logs, has this any effect on user's flow?
Comment 10 Michal Skrivanek 2015-12-04 10:43:47 EST
no, just hiding a scary log line, hence medium/low
Comment 11 Michal Skrivanek 2015-12-10 05:25:52 EST
targeting 3.6 as this may be perceived as a regression, even though it's harmless. And it does obfuscate troubleshooting...
Comment 12 Red Hat Bugzilla Rules Engine 2015-12-10 21:23:56 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 13 Francesco Romani 2015-12-18 03:08:54 EST
I see this also for console device, which IIRC makes sense for the same reason; will doublecheck and post other patches

2015-12-18 03:06:32,130 INFO  [org.ovirt.engine.core.vdsbroker.CreateVmVDSCommand] (org.ovirt.thread.pool-8-thread-27) [2218fab3] FINISH, CreateVmVDSCommand, return: WaitForLaunch, log id: 18d6e029
2015-12-18 03:06:32,130 INFO  [org.ovirt.engine.core.bll.RunVmCommand] (org.ovirt.thread.pool-8-thread-27) [2218fab3] Lock freed to object 'EngineLock:{exclusiveLocks='[b29c12fe-d0ce-4bed-b2f5-184488854d37=<VM, ACTION_TYPE_FAILED_OBJECT_LOCKED>]', sharedLocks='null'}'
2015-12-18 03:06:32,213 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-8-thread-27) [2218fab3] Correlation ID: 2218fab3, Job ID: 1163cecd-6423-4f65-b1d0-fb9e6e1d1b46, Call Stack: null, Custom Event ID: -1, Message: VM a_c7_1 was started by admin@internal (Host: kenji).
2015-12-18 03:06:36,062 INFO  [org.ovirt.engine.core.vdsbroker.VmAnalyzer] (ForkJoinPool-1-worker-10) [] VM 'b29c12fe-d0ce-4bed-b2f5-184488854d37'(a_c7_1) moved from 'WaitForLaunch' --> 'PoweringUp'
2015-12-18 03:06:36,065 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FullListVDSCommand] (ForkJoinPool-1-worker-10) [] START, FullListVDSCommand(HostName = , FullListVDSCommandParameters:{runAsync='true', hostId='b43b11bd-6108-4898-b588-152f9a74bde1', vds='Host[,b43b11bd-6108-4898-b588-152f9a74bde1]', vmIds='[b29c12fe-d0ce-4bed-b2f5-184488854d37]'}), log id: 7c043827
2015-12-18 03:06:37,076 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FullListVDSCommand] (ForkJoinPool-1-worker-10) [] FINISH, FullListVDSCommand, return: [{acpiEnable=true, emulatedMachine=pc-i440fx-rhel7.2.0, vmId=b29c12fe-d0ce-4bed-b2f5-184488854d37, memGuaranteedSize=4096, transparentHugePages=true, displaySecurePort=5901, spiceSslCipherSuite=DEFAULT, cpuType=Opteron_G2, smp=2, pauseCode=NOERR, guestNumaNodes=[Ljava.lang.Object;@4702626a, smartcardEnable=false, numaTune={nodeset=0, mode=interleave}, custom={device_e1e62ae8-3f64-4b73-b7fe-6990e0fe2703device_58e47e79-0355-4bd1-a2d5-888e73ace95fdevice_9473f34e-ab50-44d3-ae7b-d5238942f1b8device_4e98c03d-e6a6-4bf9-a89a-3ba649fa4e4e=VmDevice:{id='VmDeviceId:{deviceId='4e98c03d-e6a6-4bf9-a89a-3ba649fa4e4e', vmId='b29c12fe-d0ce-4bed-b2f5-184488854d37'}', device='unix', type='CHANNEL', bootOrder='0', specParams='[]', address='{bus=0, controller=0, type=virtio-serial, port=2}', managed='false', plugged='true', readOnly='false', deviceAlias='channel1', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}, device_e1e62ae8-3f64-4b73-b7fe-6990e0fe2703=VmDevice:{id='VmDeviceId:{deviceId='e1e62ae8-3f64-4b73-b7fe-6990e0fe2703', vmId='b29c12fe-d0ce-4bed-b2f5-184488854d37'}', device='virtio-serial', type='CONTROLLER', bootOrder='0', specParams='[]', address='{slot=0x04, bus=0x00, domain=0x0000, type=pci, function=0x0}', managed='false', plugged='true', readOnly='false', deviceAlias='virtio-serial0', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}, device_e1e62ae8-3f64-4b73-b7fe-6990e0fe2703device_58e47e79-0355-4bd1-a2d5-888e73ace95fdevice_9473f34e-ab50-44d3-ae7b-d5238942f1b8device_4e98c03d-e6a6-4bf9-a89a-3ba649fa4e4edevice_a8d31536-4701-49c3-9f07-4f67b3c671c2=VmDevice:{id='VmDeviceId:{deviceId='a8d31536-4701-49c3-9f07-4f67b3c671c2', vmId='b29c12fe-d0ce-4bed-b2f5-184488854d37'}', device='spicevmc', type='CHANNEL', bootOrder='0', specParams='[]', address='{bus=0, controller=0, type=virtio-serial, port=3}', managed='false', plugged='true', readOnly='false', deviceAlias='channel2', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}, device_e1e62ae8-3f64-4b73-b7fe-6990e0fe2703device_58e47e79-0355-4bd1-a2d5-888e73ace95f=VmDevice:{id='VmDeviceId:{deviceId='58e47e79-0355-4bd1-a2d5-888e73ace95f', vmId='b29c12fe-d0ce-4bed-b2f5-184488854d37'}', device='ide', type='CONTROLLER', bootOrder='0', specParams='[]', address='{slot=0x01, bus=0x00, domain=0x0000, type=pci, function=0x1}', managed='false', plugged='true', readOnly='false', deviceAlias='ide', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}, device_e1e62ae8-3f64-4b73-b7fe-6990e0fe2703device_58e47e79-0355-4bd1-a2d5-888e73ace95fdevice_9473f34e-ab50-44d3-ae7b-d5238942f1b8=VmDevice:{id='VmDeviceId:{deviceId='9473f34e-ab50-44d3-ae7b-d5238942f1b8', vmId='b29c12fe-d0ce-4bed-b2f5-184488854d37'}', device='unix', type='CHANNEL', bootOrder='0', specParams='[]', address='{bus=0, controller=0, type=virtio-serial, port=1}', managed='false', plugged='true', readOnly='false', deviceAlias='channel0', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}}, vmType=kvm, memSize=4096, smpCoresPerSocket=1, vmName=a_c7_1, nice=0, status=Up, maxMemSize=4194304, bootMenuEnable=false, pid=7846, copyPasteEnable=true, displayIp=192.168.1.51, displayPort=5900, guestDiskMapping={}, spiceSecureChannels=smain,sinputs,scursor,splayback,srecord,sdisplay,susbredir,ssmartcard, fileTransferEnable=true, nicModel=rtl8139,pv, keyboardLayout=en-us, kvmEnable=true, displayNetwork=ovirtmgmt, devices=[Ljava.lang.Object;@6d8b4191, display=qxl, timeOffset=0, maxVCpus=16, clientIp=, statusTime=4344219110, maxMemSlots=16}], log id: 7c043827
2015-12-18 03:06:37,119 INFO  [org.ovirt.engine.core.vdsbroker.VmsMonitoring] (ForkJoinPool-1-worker-10) [] Received a console Device without an address when processing VM b29c12fe-d0ce-4bed-b2f5-184488854d37 devices, skipping device: {alias=serial0, specParams={consoleType=serial, enableSocket=true}, deviceType=console, deviceId=63728807-c3f1-4c4d-b8de-9c2e42e18fb4, device=console, type=console}
2015-12-18 03:06:37,119 INFO  [org.ovirt.engine.core.vdsbroker.VmsMonitoring] (ForkJoinPool-1-worker-10) [] Received a memballoon Device without an address when processing VM b29c12fe-d0ce-4bed-b2f5-184488854d37 devices, skipping device: {device=memballoon, specParams={model=none}, deviceType=balloon, type=balloon, alias=balloon0}
2015-12-18 03:06:37,119 INFO  [org.ovirt.engine.core.vdsbroker.VmsMonitoring] (ForkJoinPool-1-worker-10) [] Received a spice Device without an address when processing VM b29c12fe-d0ce-4bed-b2f5-184488854d37 devices, skipping device: {tlsPort=5901, specParams={fileTransferEnable=true, copyPasteEnable=true, displayIp=192.168.1.51, displayNetwork=ovirtmgmt}, deviceType=graphics, deviceId=13b552a3-889a-41ba-8257-2f8a9ba087bc, device=spice, type=graphics, port=5900}
2015-12-18 03:06:37,119 ERROR [org.ovirt.engine.core.vdsbroker.VmsMonitoring] (ForkJoinPool-1-worker-10) [] VM 'b29c12fe-d0ce-4bed-b2f5-184488854d37' managed non pluggable device was removed unexpectedly from libvirt: 'VmDevice:{id='VmDeviceId:{deviceId='63728807-c3f1-4c4d-b8de-9c2e42e18fb4', vmId='b29c12fe-d0ce-4bed-b2f5-184488854d37'}', device='console', type='CONSOLE', bootOrder='0', specParams='[consoleType=serial, enableSocket=true]', address='', managed='true', plugged='false', readOnly='false', deviceAlias='', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}'
2015-12-18 03:06:42,201 INFO  [org.ovirt.engine.core.vdsbroker.VmAnalyzer] (DefaultQuartzScheduler_Worker-80) [] VM '563de1c8-4f9e-4f3d-8314-78d3398279a9'(a_c7_x1) moved from 'Down' --> 'Up'
Comment 14 Red Hat Bugzilla Rules Engine 2015-12-20 03:22:35 EST
Fixed bug tickets must have target milestone set prior to fixing them. Please set the correct milestone and move the bugs back to the previous status after this is corrected.
Comment 15 Red Hat Bugzilla Rules Engine 2015-12-22 06:18:21 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 16 Israel Pinto 2016-02-08 08:15:24 EST
Verify on:
RHEVM: 3.6.3-0.1.el6 
Host:
OS Version:RHEL - 7.2 - 9.el7
Kernel Version:3.10.0 - 327.el7.x86_64
KVM Version:2.3.0 - 31.el7_2.7
LIBVIRT Version:libvirt-1.2.17-13.el7_2.2
VDSM Version:vdsm-4.17.19-0.el7ev

Scenario:
1. Migrate VM 
2. Host maintenance 
3. Start VM
4. check engine log:
cat engine.log | grep 'managed non pluggable device was removed unexpectedly from libvirt'

Results:
PASS

Note You need to log in before you can comment on or make changes to this bug.