Bug 1273967 - translator libraries should use versioned symbols instead of path specific library versions
Summary: translator libraries should use versioned symbols instead of path specific li...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-21 15:29 UTC by Joe Julian
Modified: 2018-11-20 09:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-20 09:09:30 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Joe Julian 2015-10-21 15:29:40 UTC
Because we version our libraries by path, updates without remounts can cause issues during volume changes:

[2015-10-21 14:29:26.844977] I [glusterfsd-mgmt.c:56:mgmt_cbk_spec] 0-mgmt: Volume file changed
[2015-10-21 14:29:26.886861] W [MSGID: 101095] [xlator.c:194:xlator_dynload] 0-xlator: /usr/lib64/glusterfs/3.7.4/xlator/cluster/replicate.so: cannot open shared object file: No such file or directory
[2015-10-21 14:29:26.886909] E [graph.y:212:volume_type] 0-parser: Volume 'public-replicate-0', line 70: type 'cluster/replicate' is not valid or not found on this machine
[2015-10-21 14:29:26.886934] E [graph.y:321:volume_end] 0-parser: "type" not specified for volume public-replicate-0

If we used versioned symbol tables, we could theoretically support this scenario - unless I completely misunderstand their use.

Comment 1 Kaleb KEITHLEY 2015-11-03 13:43:37 UTC
Yes, symbol versions would do that.

They also add a lot of complexity to writing and maintaining xlators.

Maybe we can or should consider it for 4.0 and hit the ground running with them from the start?

Comment 2 Vijay Bellur 2018-11-20 09:39:34 UTC
Migrated to github:

https://github.com/gluster/glusterfs/issues/594

Please follow the github issue for further updates on this bug.


Note You need to log in before you can comment on or make changes to this bug.