Bug 1273973 - oc exec -tip podid -- bash doesn't work on windows
oc exec -tip podid -- bash doesn't work on windows
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.0.0
Unspecified Windows
unspecified Severity urgent
: ---
: ---
Assigned To: Fabiano Franz
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 11:53 EDT by Grant Shipley
Modified: 2015-11-23 09:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 09:24:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grant Shipley 2015-10-21 11:53:18 EDT
Description of problem:
After doing many roadshows, I have encountered the same problem with every windows user.  The following command reports as error:

oc exec -tip podid -- bash

I have seen this on roughly 100 windows machines over the last month.  However, on my windows machine it works with the only difference being that I have SSH client installed and the users at the workshop did not.

Version-Release number of selected component (if applicable):
3.0.1

How reproducible:
Every time

Steps to Reproduce:
1. Execute - oc exec -tip podid -- bash
2. see error message
3. give up

Actual results:
error message

Expected results:
should get a remote shell

Additional info:
Comment 2 Fabiano Franz 2015-10-21 17:29:03 EDT
I was not able to reproduce this (tested on a new and clean Windows 10 box from modern.ie, running on VirtualBox). Assigning to QE to check if they can reproduce.
Comment 3 Xingxing Xia 2015-10-22 01:45:58 EDT
I cannot reproduce the issue. I checked with Windows 8 guest on KVM using the latest oc version:
oc v3.0.2.902
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4

So I move this bug to VERIFIED. If you still have issues,please re-open it.
Comment 4 Brenton Leanhardt 2015-11-23 09:24:50 EST
This fix is available in OpenShift Enterprise 3.1.

Note You need to log in before you can comment on or make changes to this bug.