Bug 1273976 - redhat-support-tool caches bad password
redhat-support-tool caches bad password
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: redhat-support-tool (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Mark Huth
Martin Kyral
:
Depends On:
Blocks: 1298112
  Show dependency treegraph
 
Reported: 2015-10-21 12:03 EDT by Jason Berry
Modified: 2016-11-04 03:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1275885 (view as bug list)
Environment:
Last Closed: 2016-11-04 03:49:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Berry 2015-10-21 12:03:23 EDT
Description of problem:
When running redhat-support-tool interactively to addattachment, if you typo your username or password, it caches the bad username/password.  You have to exit r-s-t and relaunch for it to ask your username/password again

Version-Release number of selected component (if applicable):
0.9.7-1


Steps to Reproduce:
1. run 'redhat-support-tool' interactively
2. use 'addattachment' to add an attachment to a case, but typo your username or password
3. addattachment returns with an "Unauthorized message"
4. try to addattachment again, and it wont even ask for the username/password again

Actual results:
Unauthorized error, never asks for username/password agaun

Expected results:
If u/p is bad/unauthorized, re-ask for a username/password
Comment 5 Mike McCune 2016-03-28 19:05:20 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 errata-xmlrpc 2016-11-04 03:49:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2516.html

Note You need to log in before you can comment on or make changes to this bug.