Bug 1274019 - Cannot bond any virtual IPoIB interfaces if the physical ports are bonded
Cannot bond any virtual IPoIB interfaces if the physical ports are bonded
Status: CLOSED DUPLICATE of bug 1274020
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rdma (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Doug Ledford
Infiniband QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 14:05 EDT by Tom Tomer
Modified: 2015-10-27 10:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-27 10:41:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifcfg files (11.19 KB, application/zip)
2015-10-21 14:05 EDT, Tom Tomer
no flags Details

  None (edit)
Description Tom Tomer 2015-10-21 14:05:05 EDT
Created attachment 1085260 [details]
ifcfg files

Description of problem:
If we bond the two Mellanox physical ports ("ib0" & "ib1") then we cannot bond any additional virtual IPoIB interfaces. Red Hat reboots result in a hang in this case. If we do NOT bond the physical ports, then there is no problem bonding any number of additional IPoIB interfaces.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install ConnectX3 FRD Infiniband + 40GigE, P/N MCX354A-FCBT HBA in server
2. Configure bonding on both the default physical ib ports and on additional child interfaces with pkeys
3. Reboot the OS

Actual results:
Redhat hangs

Expected results:
Redhat reboots and all interfaces work

Additional info:
Attached are examples of working ifcfg files and failing files (with everything bonded).
Comment 2 Larry Troan 2015-10-27 10:41:15 EDT

*** This bug has been marked as a duplicate of bug 1274020 ***

Note You need to log in before you can comment on or make changes to this bug.