Bug 1274024 - Able to create job templates with duplicate names
Summary: Able to create job templates with duplicate names
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Remote Execution
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-21 18:17 UTC by jcallaha
Modified: 2019-09-25 21:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:20:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Duplicate names (109.00 KB, image/png)
2015-10-21 18:17 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 13218 None None None 2016-04-22 15:01:08 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description jcallaha 2015-10-21 18:17:09 UTC
Created attachment 1085262 [details]
Duplicate names

Description of problem:
You are currently able to create a job template with the same name as another.

How reproducible:
Always

Steps to Reproduce:
1. Create two job templates 
2. Alternatively, clone an existing template and save without changing the name.

Actual results:
Job template successfully created

Expected results:
Job template is rejected due to the name being already used.

Comment 3 jcallaha 2016-03-17 14:34:38 UTC
Verified in Satellite 6.2 Beta Snap 4. Field validation now catches that the name has already been taken, regardless of the job category.

Comment 6 errata-xmlrpc 2016-07-27 09:20:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.