Bug 1274032 - Revert action does not work in job templates
Summary: Revert action does not work in job templates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning Templates
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-21 18:27 UTC by jcallaha
Modified: 2019-09-25 21:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:58:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 3951 None None None 2016-04-22 15:57:21 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description jcallaha 2015-10-21 18:27:44 UTC
Description of problem:
The option to revert to a previous version is shown in the UI, however it makes no change to the contents of a job template.

Version-Release number of selected component (if applicable):
Nightly

How reproducible:
Always

Steps to Reproduce:
1. Create a job template
2. Make multiple saved revisions to the template to build up history.
3. Use the revert action to roll back the template to a previous history.

Actual results:
No change is made.

Expected results:
The template is reverted back to the desired version.

Comment 2 Bryan Kearney 2016-02-16 15:06:50 UTC
Upstream bug component is Provisioning Templates

Comment 4 jcallaha 2016-03-17 14:43:18 UTC
Verified in Satellite 6.2 Beta Snap 4. Revert action now appropriately rolls back to the expected version.

Comment 7 errata-xmlrpc 2016-07-27 08:58:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.