Bug 127404 - hangs with "words" longer than 225 characters
hangs with "words" longer than 225 characters
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-utils (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-07 15:29 EDT by Zack Cerza
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 14:43:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2004-07-07 15:29:04 EDT
Description of problem:
gnome-dictionary will hang when given a string longer than 225
characters. Clearly this is an extremely rare case, but it could still
be avoided.

Version-Release number of selected component (if applicable):
2.6.0

How reproducible:
Always

Steps to Reproduce:
1. Open gnome-dictionary.
2. Put more than 225 characters in the "Word:" box.
3. Click "Look Up Word" .
  
Actual results:
Hang.

Expected results:
gnome-dictionary attempts to look up the word.

Additional info:
while gnome-dictionary is hanging, this line is repeated in strace:
read(20, "", 4096)                      = 0
Comment 1 Christopher Aillon 2004-08-24 14:43:27 EDT
Looks like this got fixed upstream, and is now in rawhide.  Since this
is an edge case, I don't see the need to push to FC2.  Marking RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.