Bug 1274045 - Job templates: template diff and details blank on audits page
Job templates: template diff and details blank on audits page
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Remote Execution (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Marek Hulan
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 14:49 EDT by jcallaha
Modified: 2016-07-27 05:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:20:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12271 None None None 2016-04-22 12:25 EDT
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 08:28:58 EDT

  None (edit)
Description jcallaha 2015-10-21 14:49:56 EDT
Description of problem:
When clicking the "Show Diff" link in a job template, you are brought to an audits page that is blank in the template diff and details sections. The history section is correctly populated.

Version-Release number of selected component (if applicable):
Nightly

How reproducible:
Always

Steps to Reproduce:
1. Create a job template.
2. Make and save changes to the template to build a history for the template.
3. Click the "Show Diff" button
4. Visit the Template Diff and Details sections.

Actual results:
The template diff and details sections are not populated.

Expected results:
The template diff and details sections are populated correctly.
Comment 3 jcallaha 2016-03-17 10:54:49 EDT
Verified in Satellite 6.2 Beta Snap 4. The show diff functionality now works as expected.
Comment 6 errata-xmlrpc 2016-07-27 05:20:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.