Bug 1274048 - Windows XP installer stucks installing with virtio-drivers
Windows XP installer stucks installing with virtio-drivers
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: virtio-win (Show other bugs)
unspecified
Unspecified All
unspecified Severity high
: ---
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks: 1284769
  Show dependency treegraph
 
Reported: 2015-10-21 14:54 EDT by Eugene
Modified: 2016-05-16 08:36 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1284769 (view as bug list)
Environment:
Last Closed: 2016-05-16 08:36:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The moment windows XP installer stucks in VM (2.64 KB, image/png)
2015-10-21 14:54 EDT, Eugene
no flags Details

  None (edit)
Description Eugene 2015-10-21 14:54:43 EDT
Created attachment 1085269 [details]
The moment windows XP installer stucks in VM

Description of problem:

Windows XP installer stucks installing with virtio-drivers.

Version-Release number of selected component (if applicable):
virtio-win-0.1.101 - virtio-win-0.1.110-2/ (from here: https://fedorapeople.org/groups/virt/virtio-win/direct-downloads/archive-virtio/)


How reproducible:
Just create windows xp VM throuth virt-manager with Virtio Disk hardware.

Steps to Reproduce:
1. Change IDE Disk to Virtio Disk
2. Add floppy device and mount virtio-win-0.1.110_x86.vfd to it.
3. Start newly created WinXP VM from mounted winXP SP3 iso for installation.
4. Press F6 to choose virtio-drivers and then, a little later, "S" button, add VirtIO BLOCK Disk Device WinXP/32-bit. Press Enter to continue.

Actual results:
Installer stucks on "Setup is starting Windows" installer message.

Expected results:
Installation should continue.

Additional info:
The thing is installation is stucks on all virtio-win driver versions except virtio-win-0.1.100. With this version windows installer continues and allows to install Windows XP successfully.
Comment 1 Eugene 2015-10-21 14:58:22 EDT
Kubuntu 15.10
Linux 4.3.0RC6 x86_64

libvirt-bin: 1.2.16
virt-manager: 1.2.1
qemu 2.3.1
Comment 6 David Heidelberg (okias) 2015-10-28 21:12:47 EDT
I can confirm.

With machine='pc-i440fx-2.1' is latest version broken. I tested and it worked 0.1.100.

With machine='pc-0.12' it worked just fine.

Same situation applies when switching from running system on IDE to VIRTIO.
Comment 7 David Heidelberg (okias) 2015-10-28 21:46:02 EDT
< pc-0.12 not tested
> pc-0.12 && <= pc-0.14 works with latest build
> pc-0.14 works with 0.1.100, but not latest. Tested up to pc-i440fx-2.1.

I hope it helps find issue, would be nice to have working latest version
Comment 8 Vadim Rozenfeld 2015-10-29 01:01:33 EDT
Thanks,
Can reproduce on my setup. Looks like a broken driver.
Vadim.
Comment 11 David Heidelberg (okias) 2016-05-15 15:45:53 EDT
That's great, should I expect any fix comming soon?
Comment 12 Vadim Rozenfeld 2016-05-15 22:31:11 EDT
(In reply to David Heidelberg (okias) from comment #11)
> That's great, should I expect any fix comming soon?

according to https://bugzilla.redhat.com/show_bug.cgi?id=1284769#c5
the problem should be fixed in build 112. Do you still observe the same problem?
If yes, please specify qemu, kvm and virtio-win drivers versions along with qemu command line.

Best regards,
Vadim.
Comment 13 David Heidelberg (okias) 2016-05-16 07:16:10 EDT
51.73.104.11700

Works on already installed system, so I presume it'll be also fixed when installing XP.

Thank you
Comment 14 Cole Robinson 2016-05-16 08:36:01 EDT
sounds like this is fixed then, so closing. please reopen if I misunderstood

Note You need to log in before you can comment on or make changes to this bug.