Bug 1274052 - RepoRequires dependencies are not recursively fulfilled
RepoRequires dependencies are not recursively fulfilled
Status: CLOSED NEXTRELEASE
Product: Restraint
Classification: Community
Component: general (Show other bugs)
0.1.21
Unspecified Unspecified
unspecified Severity unspecified
: 0.1.25
: ---
Assigned To: Artem Savkov
tools-bugs
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 15:09 EDT by Don Zickus
Modified: 2016-04-20 20:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-24 06:22:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Zickus 2015-10-21 15:09:23 EDT
Description of problem:

I installed a test through restraint kernel/kdump/setup-bare-metal

inside that testinfo.desc is a RepoRequires: kdump/include

restraint happily adds kdump/include to the machine under test.
However, inside kdump/include's testinfo.desc is a Requires: kexec-tools.

kexec-tools is _not_ installed and thus causes issues during testing under restraint.

Under beah this works because everything is rpm based and the rpm deps are solved by yum (which includes fetch kexec-tools) correctly.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fetch_url git://....#kdump/setup-bare-metal
2.test aborts because kdumpctl is not installed (from package kexec-tools)
3.

Actual results:


Expected results:
kexec-tools is installed correctly

Additional info:
Comment 1 Artem Savkov 2016-03-21 05:57:25 EDT
Proposed patchset fixing this issue:

   http://gerrit.beaker-project.org/4743 Move metadata processing to metadata.c
   http://gerrit.beaker-project.org/4744 Get rid of global session in fetch_http.
   http://gerrit.beaker-project.org/4745 Fix rt_sigaction valgrind suppression.
   http://gerrit.beaker-project.org/4746 Prepare test_dependency for recursive repodeps.
   http://gerrit.beaker-project.org/4747 Add common 'test' to test-data.
   http://gerrit.beaker-project.org/4748 Recursively check repodeps.
   http://gerrit.beaker-project.org/4749 Add recursive dependency tests.
Comment 2 Artem Savkov 2016-03-24 06:22:39 EDT
merged

Note You need to log in before you can comment on or make changes to this bug.