Bug 1274103 - anaconda --image install runs hwclock on host system and changes the time
anaconda --image install runs hwclock on host system and changes the time
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
22
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-21 19:16 EDT by Brian Lane
Modified: 2015-10-26 17:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-23.19.10-1 anaconda-23.19.10-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 17:01:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2015-10-21 19:16:43 EDT
During an image install time_initialize is called, running hwclock --hctosys --localtime and the host's time is changed.
Comment 1 Brian Lane 2015-10-21 19:18:37 EDT
Proposed patch - https://github.com/rhinstaller/anaconda/pull/422
Comment 2 Fedora Blocker Bugs Application 2015-10-21 19:20:12 EDT
Proposed as a Freeze Exception for 23-final by Fedora user bcl using the blocker tracking app because:

 Would be nice not to make the host system's time jump around when creating images.
Comment 3 Adam Williamson 2015-10-22 13:43:52 EDT
Discussed at 2015-10-22 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-22/f23-fe-review.2015-10-22-17.30.log.txt . Accepted as a freeze exception issue: always good to avoid fiddling with the host clock when it's not necessary.

BTW, I think there might be another report of this somewhere. I'll try and find it.
Comment 4 Fedora Update System 2015-10-22 16:23:03 EDT
anaconda-23.19.10-1.fc23 python-blivet-1.12.8-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-da7ada8825
Comment 5 Fedora Update System 2015-10-24 08:09:15 EDT
anaconda-23.19.10-1.fc23, python-blivet-1.12.8-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update anaconda python-blivet'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-da7ada8825
Comment 6 Fedora Update System 2015-10-26 17:01:06 EDT
anaconda-23.19.10-1.fc23, python-blivet-1.12.8-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.