Bug 1274104 - [RFE] add --sshkey option to sshpw kickstart command
[RFE] add --sshkey option to sshpw kickstart command
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: FutureFeature
Depends On: 1240410
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 19:56 EDT by Brian Lane
Modified: 2016-02-24 11:08 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-24.7-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1240410
Environment:
Last Closed: 2016-02-24 11:08:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2015-10-21 19:56:41 EDT
+++ This bug was initially created as a clone of Bug #1240410 +++

Description of problem:
When using the inst.sshd option and a kickstart installation, using authorized keys would be appreciated.  the sshpw functionality is already there.

Version-Release number of selected component (if applicable): rhel 7.1 release media


How reproducible: Always


Steps to Reproduce:
1. start installation with inst.sshd boot command and sshkey kickstart option
2.
3.

Actual results:
Unknown command: sshkey

Expected results:
Able to authenticate using pubkey to the installing system

Additional info:

--- Additional comment from RHEL Product and Program Management on 2015-07-06 13:38:39 PDT ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Brian Lane on 2015-10-21 16:55:44 PDT ---

sshkey is for setting the sshkeys of users on the installed system, not during installation.

We could probably add a --sshkey argument to the sshpw command, but this will have to happen in upstream Fedora Anaconda first.

Note You need to log in before you can comment on or make changes to this bug.