Bug 1274116 - kdesu doesn't offer to save password
kdesu doesn't offer to save password
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kf5-kdesu (Show other bugs)
23
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 21:14 EDT by Loïc Yhuel
Modified: 2015-11-04 17:23 EST (History)
7 users (show)

See Also:
Fixed In Version: kf5-kdesu-5.15.0-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-01 20:21:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Loïc Yhuel 2015-10-21 21:14:33 EDT
Description of problem:
kdesu password prompt dialog asks for root password, but doesn't offer to save it, so we have to type it every time


Version-Release number of selected component (if applicable):
kdesu-5.4.2-1.fc23.x86_64

How reproducible:
launch "kdesu kwrite" for example, or configure an laucnher to run as a different user in kmenuedit

Actual results:
kdesu dialog with command text, and password input

Expected results:
kdesu dialog with additional "Remember password" checkbox

Additional info:
kdesu prints a warning :
org.kde.kdesu: Daemon not safe (not sgid), not using it.

After chmod g+s /usr/libexec/kf5/kdesud, the issue is fixed.
Comment 1 Rex Dieter 2015-10-21 22:15:03 EDT
Thanks for the detailed report.

%changelog
* Wed Oct 21 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.15.0-2
- .spec cosmetics, update URL, use %%license
- kdesu doesn't offer to save password (#1274116)
Comment 2 Fedora Update System 2015-10-21 22:52:31 EDT
kf5-kdesu-5.15.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-51b5d63ae6
Comment 3 Fedora Update System 2015-10-21 22:53:20 EDT
kf5-kdesu-5.15.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b579061771
Comment 4 Fedora Update System 2015-10-24 08:08:28 EDT
kf5-kdesu-5.15.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kf5-kdesu'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-51b5d63ae6
Comment 5 Fedora Update System 2015-10-26 14:29:46 EDT
kf5-kdesu-5.15.0-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kf5-kdesu'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b579061771
Comment 6 Fedora Update System 2015-11-01 20:21:06 EST
kf5-kdesu-5.15.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Andre Robatino 2015-11-02 14:58:45 EST
Not installable in F23 due to broken deps (see my comment in https://bodhi.fedoraproject.org/updates/FEDORA-2015-51b5d63ae6 - this was also noticed by the depcheck tests, which failed).
Comment 8 Fedora Update System 2015-11-04 17:23:09 EST
kf5-kdesu-5.15.0-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.