Bug 1274118 - Get blank page when access tomcat app with tomcat-websocket-chat contextdir and https://github.com/jboss-openshift/openshift-quickstarts source code
Get blank page when access tomcat app with tomcat-websocket-chat contextdir a...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: kconner
XiuJuan Wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 21:58 EDT by XiuJuan Wang
Modified: 2016-09-27 05:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-27 05:30:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
websocket-chat web page (72.72 KB, image/jpeg)
2015-11-19 20:30 EST, kconner
no flags Details

  None (edit)
Description XiuJuan Wang 2015-10-21 21:58:32 EDT
Description of problem:
Met 503 error when access tomcat app which build with https://github.com/jboss-openshift/openshift-quickstarts source code

Check app pod, have an unhealthy event in describe info.
# oc  describe  pods jws-app-3-8fzuz 
Name:                                jws-app-3-8fzuz
Namespace:                        tomcat7
Image(s):                        172.30.100.181:5000/tomcat7/jws-app@sha256:27b58a1aaefe0eeff53ea4e76816f3758cf718007399a27caab9803d36d6dd2f
Node:                                openshift-154.lab.eng.nay.redhat.com/10.66.79.154
Start Time:                        Wed, 21 Oct 2015 17:06:39 +0800
Labels:                                application=jws-app,deployment=jws-app-3,deploymentConfig=jws-app,deploymentconfig=jws-app
Status:                                Running
Replication Controllers:        jws-app-3 (1/1 replicas created)
Containers:
  jws-app:
    Container ID:        docker://e542875e7d76376802810b215d46fd9104c3073fd1ed4b3097f7c2bf6b216f7c
    Image:                172.30.100.181:5000/tomcat7/jws-app@sha256:27b58a1aaefe0eeff53ea4e76816f3758cf718007399a27caab9803d36d6dd2f
    Image ID:                docker://d2e5263a0173a52016aeb43fb43401b48622a09e3468162b9045ba4ca223ca85
    State:                Running
      Started:                Wed, 21 Oct 2015 17:07:36 +0800
    Ready:                True
    Restart Count:        0
    Environment Variables:
      DB_SERVICE_PREFIX_MAPPING:        jws-app-mongodb=DB
      DB_JNDI:                                
      DB_USERNAME:                        userfPj
      DB_PASSWORD:                        o4HMgQ0p
      DB_DATABASE:                        root
      DB_ADMIN_PASSWORD:                SEGbK5ja
      DB_MIN_POOL_SIZE:                        
      DB_MAX_POOL_SIZE:                        
      DB_TX_ISOLATION:                        
      JWS_HTTPS_CERTIFICATE_DIR:        /etc/jws-secret-volume
      JWS_HTTPS_CERTIFICATE:                server.crt
      JWS_HTTPS_CERTIFICATE_KEY:        server.key
      JWS_HTTPS_CERTIFICATE_PASSWORD:        
      JWS_ADMIN_USERNAME:                BuFSvv21
      JWS_ADMIN_PASSWORD:                jo6N0o7S
Conditions:
  Type                Status
  Ready         True 
Volumes:
  jws-certificate-volume:
    Type:        Secret (a secret that should populate this volume)
    SecretName:        jws-app-secret
  jws-service-account-token-y72hh:
    Type:        Secret (a secret that should populate this volume)
    SecretName:        jws-service-account-token-y72hh
Events:
  FirstSeen        LastSeen        Count        From                                                SubobjectPath                                Reason                Message
  ─────────        ────────        ─────        ────                                                ─────────────                                ──────                ───────
  19m                19m                1        {scheduler }                                                                                Scheduled        Successfully assigned jws-app-3-8fzuz to openshift-154.lab.eng.nay.redhat.com
  19m                19m                1        {kubelet openshift-154.lab.eng.nay.redhat.com}        implicitly required container POD        Pulled                Container image "registry.access.redhat.com/openshift3/ose-pod:v3.0.2.901" already present on machine
  19m                19m                1        {kubelet openshift-154.lab.eng.nay.redhat.com}        implicitly required container POD        Created                Created with docker id d79c07047dfb
  19m                19m                1        {kubelet openshift-154.lab.eng.nay.redhat.com}        implicitly required container POD        Started                Started with docker id d79c07047dfb
  19m                19m                1        {kubelet openshift-154.lab.eng.nay.redhat.com}        spec.containers{jws-app}                Pulling                Pulling image "172.30.100.181:5000/tomcat7/jws-app@sha256:27b58a1aaefe0eeff53ea4e76816f3758cf718007399a27caab9803d36d6dd2f"
  19m                19m                1        {kubelet openshift-154.lab.eng.nay.redhat.com}        spec.containers{jws-app}                Pulled                Successfully pulled image "172.30.100.181:5000/tomcat7/jws-app@sha256:27b58a1aaefe0eeff53ea4e76816f3758cf718007399a27caab9803d36d6dd2f"
  19m                19m                1        {kubelet openshift-154.lab.eng.nay.redhat.com}        spec.containers{jws-app}                Created                Created with docker id e542875e7d76
  18m                18m                1        {kubelet openshift-154.lab.eng.nay.redhat.com}        spec.containers{jws-app}                Started                Started with docker id e542875e7d76
  18m                18m                3        {kubelet openshift-154.lab.eng.nay.redhat.com}        spec.containers{jws-app}                Unhealthy        Readiness probe failed: 


Version-Release number of selected component (if applicable):

https://github.com/jboss-openshift/application-templates/
https://github.com/jboss-openshift/openshift-quickstarts

How reproducible:
always

Steps to Reproduce:
1.Create secret for tomcat app
2.Create a tomcat app with templete
$wget https://raw.githubusercontent.com/jboss-openshift/application-templates/master/webserver/jws-tomcat7-basic-s2i.json
oc new-app jws-tomcat7-basic-s2i.json
2.Access app after builder image deploy successfully.
3.

Actual results:
2.Can't access tomcat app, met 503 error

Expected results:
Could access app.

Additional info:
Comment 2 XiuJuan Wang 2015-11-06 00:53:29 EST
This bug can't reproduce in OSE 3.1 env
oc v3.1.0.0
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
webserver30-tomcat7-openshift  a5b8fb83551c
webserver30-tomcat8-openshift  a322aa32c91a
Please help change status to on_qa.
Thanks!
Comment 3 XiuJuan Wang 2015-11-16 02:41:21 EST
Sorry, please ingore comment #2. 
Updated bug title and bug descrition.

jws-tomcat7-basic-s2i.json and jws-tomcat8-basic-s2i.json template files both use tomcat-websocket-chat as contextdir with https://github.com/jboss-openshift/openshift-quickstarts source repo.When create these files create apps,the app page will be blank.

Works for the following template files that using todolist as contextdir with https://github.com/jboss-openshift/openshift-quickstarts source repo.

jws30-tomcat7-mongodb-persistent-s2i.json     
jws30-tomcat8-mongodb-persistent-s2i.json
jws30-tomcat7-mongodb-s2i.json                
jws30-tomcat8-mongodb-s2i.json
jws30-tomcat7-mysql-persistent-s2i.json       
jws30-tomcat8-mysql-persistent-s2i.json
jws30-tomcat7-mysql-s2i.json                  
jws30-tomcat8-mysql-s2i.json
jws30-tomcat7-postgresql-persistent-s2i.json  
jws30-tomcat8-postgresql-persistent-s2i.json
jws30-tomcat7-postgresql-s2i.json            
jws30-tomcat8-postgresql-s2i.json
Comment 4 kconner 2015-11-19 20:30 EST
Created attachment 1096967 [details]
websocket-chat web page

You will see this when you access the websocket-chat example
Comment 5 XiuJuan Wang 2015-12-02 21:58:13 EST
kconner,
When access websocket-chat, I got the  same page as your attachment.
Could you help to move the bug to on_qa status?
Thanks!
Comment 7 XiuJuan Wang 2016-06-06 21:46:04 EDT
@kconner
As my comment #5 said, could you help to set this bug to on_qa status, thanks.
Comment 8 XiuJuan Wang 2016-07-24 21:50:38 EDT
According to the comment #5 , move this bug to verified.
Comment 11 errata-xmlrpc 2016-09-27 05:30:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933

Note You need to log in before you can comment on or make changes to this bug.