This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1274193 - mcelog AMD Processor family 21: Please load edac_mce_amd module
mcelog AMD Processor family 21: Please load edac_mce_amd module
Status: CLOSED DUPLICATE of bug 1069652
Product: Fedora
Classification: Fedora
Component: mcelog (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Prarit Bhargava
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 04:46 EDT by Petr Schindler
Modified: 2015-10-22 15:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 15:14:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2015-10-22 04:46:30 EDT
Description of problem:
This seems to be the same bug as bug 1069652.

After clean installation of F23 RC2 there is failed mcelog.service after boot.



    ● mcelog.service - Machine Check Exception Logging Daemon
       Loaded: loaded (/usr/lib/systemd/system/mcelog.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Thu 2015-10-22 12:04:36 CEST; 13min ago
      Process: 846 ExecStart=/usr/sbin/mcelog --ignorenodev --daemon --foreground (code=exited, status=1/FAILURE)
      Process: 823 ExecStartPre=/etc/mcelog/mcelog.setup (code=exited, status=0/SUCCESS)
     Main PID: 846 (code=exited, status=1/FAILURE)
     
    Oct 22 12:04:36 dhcp-28-139.brq.redhat.com systemd[1]: Starting Machine Check Exception Logging Daemon...
    Oct 22 12:04:36 dhcp-28-139.brq.redhat.com mcelog.setup[823]: CPU is unsupported
    Oct 22 12:04:36 dhcp-28-139.brq.redhat.com systemd[1]: Started Machine Check Exception Logging Daemon.
    Oct 22 12:04:36 dhcp-28-139.brq.redhat.com systemd[1]: mcelog.service: Main process exited, code=exited, status=1/FAILURE
    Oct 22 12:04:36 dhcp-28-139.brq.redhat.com systemd[1]: mcelog.service: Unit entered failed state.
    Oct 22 12:04:36 dhcp-28-139.brq.redhat.com systemd[1]: mcelog.service: Failed with result 'exit-code'.
    Oct 22 12:04:36 dhcp-28-139.brq.redhat.com mcelog[846]: mcelog: AMD Processor family 21: Please use the edac_mce_amd module instead.
    Oct 22 12:04:36 dhcp-28-139.brq.redhat.com mcelog[846]: : Success
    Oct 22 12:04:36 dhcp-28-139.brq.redhat.com mcelog[846]: CPU is unsupported
     


Version-Release number of selected component (if applicable):
mcelog-101-2.9bfaad8f92c5.fc23.x86_64

How reproducible:
always with this pc.

Steps to Reproduce:
1. Install Server from F23 Server DVD RC2
2. Boot and log in
3. systemctl --failed --all

Actual results:
mcelog.service failed

Expected results:


Additional info:
I propose this as a blocker as it violates the criterion: "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present."

I'm -1 blocker as it probably happens only on one particular processor family.
Comment 1 Adam Williamson 2015-10-22 11:55:16 EDT
CCing jwb as this seems to involve kernel stuff.
Comment 2 Adam Williamson 2015-10-22 12:58:48 EDT
Discussed at 2015-10-22 Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-2/2015-10-22/f23-final-go_no_go-meeting.2015-10-22-16.00.log.txt . Rejected as a blocker, as it seems pretty clearly limited to a specific processor family, and it's only really a polish bug - it doesn't have any severe consequence. (The criterion is there for polish purposes, it looks bad if there's a failing service on *every* install, or a large chunk of them).
Comment 3 Josh Boyer 2015-10-22 15:12:14 EDT
(In reply to awilliam@redhat.com from comment #1)
> CCing jwb as this seems to involve kernel stuff.

There's a whole kernel team, not just me.  Feel free to CC kernel-team@fedoraproject.org.

For this specific bug, Prarit already described what is happening in the bug Petr pointed to.  You might as well mark this as a duplicate.
Comment 4 Adam Williamson 2015-10-22 15:14:09 EDT
ah, sorry - didn't realize there was a BZ alias. I just use you as a proxy. :P

dupe sounds good. also, i should fix my bureaucracy!

*** This bug has been marked as a duplicate of bug 1069652 ***

Note You need to log in before you can comment on or make changes to this bug.