Bug 1274202 - Permission denied if try to make changes inside pod of ruby-22-rhel7
Permission denied if try to make changes inside pod of ruby-22-rhel7
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-ruby22-docker (Show other bugs)
rh-ruby22
Unspecified Unspecified
medium Severity medium
: rc
: 2.1
Assigned To: Josef Stribny
XiuJuan Wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 05:02 EDT by Wenjing Zheng
Modified: 2015-11-16 11:08 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 11:08:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
xiuwang: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Wenjing Zheng 2015-10-22 05:02:02 EDT
Description of problem:
Permission denied when try to make changes inside pod of php-56-rhel7, ruby-20-rhel7 and ruby-22-rhel7 app

Version-Release number of selected component (if applicable):
php-56-rhel7  057b1c7fdae1
ruby-22-rhel7  a6c37f6f13e2
ruby-20-rhel7 813c1ad3ce3a

How reproducible:
always

Steps to Reproduce:
1. Create a new project and imagestream
$oc new-project test
$ oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/image-streams/extra-image-streams-rhel7.json
2. Create a application with php-56-centos7
$oc new-app test/perl~https://github.com/wzheng1/php-example-app.git  -p OPCACHE_REVALIDATE_FREQ=0
3. Check the build completes successfully
4. Go into the result image with docker command
$oc rsh  <POD_ID>
bash-4.2$ vi index.php
bash-4.2$ pwd
/opt/app-root/src

Actual results:
Permission denied when try to edit.

Expected results:
It should be editable like php-55-rhel7, ruby-20-rhel7 and ruby-20-rhel7.

Additional info:
Comment 8 Wenjing Zheng 2015-10-26 01:44:07 EDT
Since php-56-rhel7 and ruby-20-rhel7 are rebuilt and tested, no such issue now; is seems ruby-22-rhel7 hasn't been rebuilt, still have such issue. So leave this bug only to track ruby-22-rhel7 now.
rhscl/ruby-22-rhel7     a6c37f6f13e2        4 weeks ago
Comment 9 Ben Parees 2015-10-26 16:07:49 EDT
Honza's team owns rebuilding ruby-22, assigning to him.
Comment 10 Honza Horak 2015-10-28 11:41:08 EDT
Moving to the rh-ruby22-docker component of RHSCL, so we track it as part of RHSCL development. If you need a bug to track issue in OpenShift, please, change it back and create a separate bug for RHSCL.
Comment 14 XiuJuan Wang 2015-11-04 08:46:41 EST
As the comment #13, move the bug to verified status.
Comment 17 errata-xmlrpc 2015-11-16 11:08:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2057.html

Note You need to log in before you can comment on or make changes to this bug.