Bug 1274266 - [RFE] Add job scheduler to RHEV
[RFE] Add job scheduler to RHEV
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: nobody nobody
Pavel Stehlik
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 07:38 EDT by Anand Nande
Modified: 2017-06-19 07:40 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-19 07:40:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Nande 2015-10-22 07:38:07 EDT
2. Who is the customer behind the request?  
Account: 	Specsavers Optical Group (acc.no=928024)
  
TAM customer: yes  
SRM customer: no
Strategic: yes  
  
3. What is the nature and description of the request?  

RHEV should include the ability to allow tasks such as VM snapshots, VM shutdown/startup/reboot, Disk Moves etc to happen at specified time/date automatically.

  
4. Why does the customer need this? (List the business requirements here)  
  
Customer runs production systems on RHEV, and as such only have narrow service windows in which to make changes. 
These are sometime early hours of the morning and require on-call staff to execute simple jobs that would benefit from automation
Deployments of software updates etc are run on a schedule, and to safeguard data, if a VM snapshot could be scheduled to occur before
deployments are due to go out, would allow for easy roll back in case of issues.

5. How would the customer like to achieve this? (List the functional requirements here)  

Facility when executing a job to either run now, at a specific time (one-off) or regularly (daily, weekly etc) maybe as a cron 
style format as well. The ability to chain tasks together, eg to take a snapshot, then when that is complete to create a clone 
based on that snapshot.
  
6. Is there already an existing RFE upstream or in Red Hat Bugzilla?  

There are some methods for automation like:

- VM Backup scheduler  : https://github.com/ovirt-china/vm-backup-scheduler/wiki/Installation
- Start ALL Vms : https://github.com/humblec/python-sdk-ovirt/blob/master/start_all_down_vms.py
- Stop ALL Vms: https://github.com/humblec/python-sdk-ovirt/blob/master/shutdown_all_up_vms.py

  
7. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  N/A
  
10. List any affected packages or components: ovirt-engine-webadmin portal
  
11. Would the customer be able to assist in testing this functionality if implemented?  Yes
Comment 6 Moran Goldboim 2017-06-19 07:40:46 EDT
Closing this bug, as we plan to attend this use case in CloudForms/Tower integration.

Note You need to log in before you can comment on or make changes to this bug.