Bug 127427 - bluez-utils not 64bit safe.
Summary: bluez-utils not 64bit safe.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez-utils   
(Show other bugs)
Version: 2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-08 01:42 UTC by Sam Varshavchik
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 11:36:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix 64bit issues. (783 bytes, text/plain)
2004-07-08 01:44 UTC, Sam Varshavchik
no flags Details

Description Sam Varshavchik 2004-07-08 01:42:51 UTC
FWIW bluez-utils has problems on 64bit platforms.  Looking upstream it
looks like this has already been fixed in bluez-utils 2.7; however
there might be some dependencies issues.  The alternative is the
following small patch.

Comment 1 Sam Varshavchik 2004-07-08 01:44:05 UTC
Created attachment 101707 [details]
Patch to fix 64bit issues.

This patch keeps hcid from dumping core on x86_64.

Comment 2 Bastien Nocera 2004-09-02 16:59:33 UTC
bluez-utils 2.10 is now in rawhide. Does it fix the problem for you?

Comment 3 Sam Varshavchik 2004-09-04 00:23:24 UTC
I don't know.  Updating to bluez-utils in rawhide also requires an
update of gnome-bluetooth-utils, and attempting to initiating a file
transfer from my bluetooth cellphone now crashes gnome-obex-server:

poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN, revents=POLLIN},
{fd=8, events=POLLIN|POLLPRI}, {fd=10, events=POLLIN}, {fd=12,
events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=14,
events=POLLIN|POLLPRI}, {fd=15, events=POLLIN}, {fd=16,
events=POLLIN}, {fd=17, events=POLLIN}], 10, -1) = 1
ioctl(3, FIONREAD, [64])                = 0
read(3,
"\5\1\211\2K\275\t\0@\0\0\0?\0\200\2\0\0\0\0\264\3\242\1.\0\17\0\0\1\1\0n\2\211\2K\275\t\0\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0
\1\5\0\0", 64) = 64
read(16, 0x562408, 260)                 = -1 EAGAIN (Resource
temporarily unavailable)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---

This bug is _probably_ fixed, because hcid itself is not crashing (the
original bug).


Comment 4 David Woodhouse 2005-03-02 11:36:24 UTC
Reopen if you're still desperate for a fix in FC2. 


Note You need to log in before you can comment on or make changes to this bug.