Bug 127430 - Multimedia Keys not working
Multimedia Keys not working
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-07 23:10 EDT by Thomas Schuett
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-19 14:49:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Schuett 2004-07-07 23:10:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040612 Firefox/0.8

Description of problem:
I'm using an IBM Rapid Access II Keyboard and only some keys are not
working. The Problem seems to be the keymap loaded my loadkeys on startup.

showkey -s output for "Volume Up" Button:
atkbd.c: Unknown key pressed (translated set 2, code 0xa3 on
isa0060/serio0).
atkbd.c: Use 'setkeycodes e023 <keycode>' to make it known.
atkbd.c: Unknown key released (translated set 2, code 0xa3 on
isa0060/serio0).
atkbd.c: Use 'setkeycodes e023 <keycode>' to make it known.

/etc/sysconfig/keyboard reads:
KEYBOARDTYPE="pc"
KEYTABLE="de-latin1"

The Keyboard used to work completly in FC1.



Version-Release number of selected component (if applicable):
kbd-1.12-1

How reproducible:
Always

Steps to Reproduce:
1. start showkey or xev
2. Hit special keys on Rapid Acess II Keyboard ("Volume up, "Mute"...)

    

Actual Results:  Keyboard events are not created.

Expected Results:  Keyboard events are created, 

Additional info:

The problem is probably the same in bug 123112.
Comment 1 Pontus Enhager 2004-07-13 16:28:14 EDT
I see the same problem on a Microsoft Wireless Natural MultiMedia
keyboard (with different keycodes of course) - everything worked just
fine in FC1.

If needed i can provide furhter information or file a separate bug for
my keyboard.

dmesg is e.g. filled with:
atkbd.c: Use 'setkeycodes e001 <keycode>' to make it known.
atkbd.c: Unknown key released (translated set 2, code 0x81 on
isa0060/serio0).
Comment 2 Thomas Schuett 2004-11-12 10:39:43 EST
Still present in FC3
Comment 3 Miloslav Trmač 2005-02-19 14:49:14 EST
The scan codes have to be mapped to keycodes for keymaps to apply at all;
you can do it manually using setkeycodes(8), as described in the log messages.

The mapping could also be added in the kernel by default, to avoid
the need to use setkeycodes(8), but that's not always possible;
e.g. there already is a mapping for "volume up" using scancode sequence
e0 30; having two different scancode sequences for the same key could
be losing information.

If the scancode->keycode mapping were changed, it should be done
upstream to minimize gratituous incompatibilities between Fedora and
upstream kernels; feel free to  suggest adding the scancode->keycode
mapping to the upstream kernel maintainers.

Note You need to log in before you can comment on or make changes to this bug.