Bug 1274319 - Put dnf's yumdb on live images
Put dnf's yumdb on live images
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Václav Pavlín
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-22 09:28 EDT by Kalev Lember
Modified: 2015-10-30 11:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 11:28:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[PATCH] live base: Migrate yum's yumdb over to dnf (1.19 KB, text/plain)
2015-10-22 09:28 EDT, Kalev Lember
no flags Details

  None (edit)
Description Kalev Lember 2015-10-22 09:28:11 EDT
Created attachment 1085506 [details]
[PATCH] live base: Migrate yum's yumdb over to dnf

Right now live iso images are all generated with livecd-creator, which internally still uses yum. The images itself only include dnf and yum is long gone.

Since livecd-creator is yum based, it creates a /var/lib/yum/yumdb as part of the installation. This however doesn't work for DNF and PackageKit which are reading and writing the yumdb in /var/lib/dnf/yumdb.

I would like to fix this for Fedora 23 by moving the yumdb to the correct location in kickstart %post script. I discussed this with jsilhan from the DNF team and he agrees this makes sense.

One visible thing it fixes is showing the source repo for installed packages in gnome-software.

Before: https://kalev.fedorapeople.org/gnome-software-yumdb1.png
After: https://kalev.fedorapeople.org/gnome-software-yumdb2.png

Proposing as a freeze exception as it's an issue that is difficult to fix with an update, and it fixes a visible gnome-software UI problem on the live media.
Comment 1 Adam Williamson 2015-10-22 13:47:24 EDT
Discussed at 2015-10-22 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-22/f23-fe-review.2015-10-22-17.30.log.txt . Accepted as a freeze exception issue: this seems like a logical change that fixes at least one visible thing in the live image.

Er, are we sure a yum-written DB will always be compatible with DNF, though?
Comment 2 Kalev Lember 2015-10-22 14:29:05 EDT
Thanks, pushed to spin-kickstarts f23 and master.

As for compatibility, it's supposed to be compatible. :)

Luckily we don't need to care about full compatibility with any old yumdb out there, only need to make sure that the freshly produced yumdb that's created during the image compose works.

Note You need to log in before you can comment on or make changes to this bug.