Bug 1274325 - Facter sends wrong data about bond and nics number
Facter sends wrong data about bond and nics number
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hosts (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Marek Hulan
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 09:37 EDT by Tareq Alayan
Modified: 2016-07-27 04:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:58:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (59.27 KB, image/png)
2015-10-22 09:37 EDT, Tareq Alayan
no flags Details
production (53.86 KB, text/plain)
2015-10-22 09:38 EDT, Tareq Alayan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 10607 None None None 2016-04-22 11:39 EDT

  None (edit)
Description Tareq Alayan 2015-10-22 09:37:14 EDT
Created attachment 1085523 [details]
screenshot

Description of problem:

facter output: 
root@talayan-foreman-test network-scripts]# facter 
architecture => x86_64
augeasversion => 1.4.0
bios_release_date => 01/01/2007
bios_vendor => Seabios
bios_version => 0.5.1
blockdevice_sr0_model => QEMU DVD-ROM
blockdevice_sr0_size => 1073741312
blockdevice_sr0_vendor => QEMU
blockdevice_vda_size => 12884901888
blockdevice_vda_vendor => 0x1af4
blockdevices => sr0,vda
domain => scl.lab.tlv.redhat.com
facterversion => 2.4.1
filesystems => ext2,ext3,ext4,xfs
fqdn => talayan-foreman-test.scl.lab.tlv.redhat.com
gid => root
hardwareisa => x86_64
hardwaremodel => x86_64
hostname => talayan-foreman-test
id => root
interfaces => bond0,ens3,lo
ipaddress => 10.35.97.177
ipaddress_ens3 => 10.35.97.177
ipaddress_lo => 127.0.0.1
is_virtual => true
kernel => Linux
kernelmajversion => 3.10
kernelrelease => 3.10.0-322.el7.x86_64
kernelversion => 3.10.0
macaddress => 32:b0:3c:d3:79:d2
macaddress_bond0 => 32:b0:3c:d3:79:d2
macaddress_ens3 => 00:1a:4a:16:97:b1
manufacturer => Red Hat
memoryfree => 756.84 MB
memoryfree_mb => 756.84
memorysize => 991.22 MB
memorysize_mb => 991.22
mtu_bond0 => 1500
mtu_ens3 => 1500
mtu_lo => 65536
netmask => 255.255.255.0
netmask_ens3 => 255.255.255.0
netmask_lo => 255.0.0.0
network_ens3 => 10.35.97.0
network_lo => 127.0.0.0
operatingsystem => RedHat
operatingsystemmajrelease => 7
operatingsystemrelease => 7.2
os => {"name"=>"RedHat", "family"=>"RedHat", "release"=>{"major"=>"7", "minor"=>"2", "full"=>"7.2"}}
osfamily => RedHat
partitions => {"vda1"=>{"uuid"=>"d14b48a2-a36a-4b40-8ffd-117ef4cf2e13", "size"=>"409600", "mount"=>"/boot", "filesystem"=>"ext3"}, "vda2"=>{"uuid"=>"ae57dbc3-1f5a-4b6f-9d15-320b6992bdb3", "size"=>"2516992", "filesystem"=>"swap"}, "vda3"=>{"size"=>"22237184", "filesystem"=>"LVM2_member"}}
path => /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin
physicalprocessorcount => 1
processor0 => Intel Celeron_4x0 (Conroe/Merom Class Core 2)
processorcount => 1
processors => {"models"=>["Intel Celeron_4x0 (Conroe/Merom Class Core 2)"], "count"=>1, "physicalcount"=>1}
productname => RHEV Hypervisor
ps => ps -ef
puppetversion => 3.7.4
rubyplatform => x86_64-linux
rubysitedir => /usr/local/share/ruby/site_ruby/
rubyversion => 2.0.0
selinux => true
selinux_config_mode => enforcing
selinux_config_policy => unknown
selinux_current_mode => enforcing
selinux_enforced => true
selinux_policyversion => 28
serialnumber => 2B89696C-9F9E-11E0-A1BE-5CF3FC7818A8_5c:f3:fc:78:18:a8
sshecdsakey => AAAAE2VjZHNhLXNoYTItbmlzdHAyNTYAAAAIbmlzdHAyNTYAAABBBCLc6Ado6sThWArwgOkS9DTjtfxai56ASOb90Khi0dwmRuiyZ7AsBV7OSGjyIHlTCbkHWC/9jSLmBnL8GXjKa18=
sshed25519key => AAAAC3NzaC1lZDI1NTE5AAAAIIaQm4UYDHSOqBBPnVKXN49ov2KPTWdWrJpYrEjbZAsM
sshfp_ecdsa => SSHFP 3 1 cd6084b1b324c68b1ea91447866fc4f34d2dc618
SSHFP 3 2 738b88f36e9227cf4f78592786278d37caa05d546c76374f17c19d46d368ef97
sshfp_ed25519 => SSHFP 4 1 66b872aeb3e023fa02468f713fb484d7d5b081c0
SSHFP 4 2 5efdc5e0f08dd6c09f45d38c5a78310a596d82c0c6dbb8a560cab13841b8ee22
sshfp_rsa => SSHFP 1 1 dff3369ff22d2e7dc90cdd2528f64b156cba12aa
SSHFP 1 2 639864886d6cd9e8cbf38ee9fdcf7c8ec54407ffb9078bdd1965ce659ee6c7df
sshrsakey => AAAAB3NzaC1yc2EAAAADAQABAAABAQCvKEZVsHlrfJAed4YHjYBlzBRGazl4DAqOAP+YSo8+M4hIZztfik3Huajfc4j7agMe073dvKQe36CwYYiXRyhQXnGlVooVvo5M+YGPdHjODiUiNXHbvFPUD1aF4RduJZM6YcqRvysqD39y0KSzkj/Ws0kUnxrcnkujGTYCliMpwHS9PU5mPbazEbii3HOfCtOv3AntqH8O8eSrVtODj1HLPHBRzH84tBfHSSZIghNKkN8q8AL5+99GNq9CARoET/G85hFwatznc4fJEfP4Hm7hpGyRdoewuiuv8qv+CoCLGCuA2P5h5nuD3ylOziqR2FTmS2kz+fFPeVLIduSDhyEX
swapfree => 1.20 GB
swapfree_mb => 1229.00
swapsize => 1.20 GB
swapsize_mb => 1229.00
system_uptime => {"seconds"=>3870, "hours"=>1, "days"=>0, "uptime"=>"1:04 hours"}
timezone => UTC
type => Other
uniqueid => 00000000
uptime => 1:04 hours
uptime_days => 0
uptime_hours => 1
uptime_seconds => 3870
uuid => 3EB188C9-5925-4DDC-AC5F-5FFBA558C2F4
virtual => kvm


Version-Release number of selected component (if applicable):
6.1.1

screenshot attached. 

Note that i couldn't delete them from UI.
Comment 1 Tareq Alayan 2015-10-22 09:38 EDT
Created attachment 1085527 [details]
production
Comment 4 Ohad Levy 2015-11-01 04:00:53 EST
AFAIU the version of facter that you use is not used within Satellite, not that I think it would make a big difference, but could you please either open it upstream (if you are using upstream puppet vs sat) or change the version of facter to the one we ship in sat6?
Comment 5 Ohad Levy 2015-11-01 04:01:14 EST
Marek, could you please also have a look?
Comment 6 Marek Hulan 2015-11-23 08:47:26 EST
It seems that the bond interfaces was created multiple times, each time it got different MAC. We detect the existing interface based on MAC and identifier, in this case MAC has changed. In next version of Satellite, for bonds we use identifier only as MAC is suppose to change frequently. For more details, see upstream issue - http://projects.theforeman.org/issues/10607
Comment 10 Sachin Ghai 2016-04-20 08:54:48 EDT
Verified with sat6.2 beta snap8.2

I created a host with eth0 and eth1 and attached these interfaces  to a bond interface and provisioned a host. Host was provisioned successfully. and I can see only one entry of bond interface after rebooting the host and even I restarted network service couple of times.

However, I see some mismatch from CLI and UI..

See how UI shows the interfaces with mac

bond0 	Bond
virtual attached to eth0,eth1
52:54:00:d8:ed:67 192.168.100.28 bondhost2.idmqe.lab.eng.bos.redhat.com 	
eth0 	Interface

physical @ NAT foreman
52:54:00:a4:39:ec  192.168.100.27 bond.idmqe.lab.eng.bos.redhat.com 	
eth1 	Interface

physical @ NAT foreman
52:54:00:d8:ed:67 192.168.100.121 bondhost1.idmqe.lab.eng.bos.redhat.com
Comment 11 Sachin Ghai 2016-04-20 08:55:59 EDT
Correct configuration in UI as :

bond0 	Bond
virtual attached to eth0,eth1
52:54:00:d8:ed:67 192.168.100.28 bondhost2.idmqe.lab.eng.bos.redhat.com 	


eth0 	Interface
physical @ NAT foreman
52:54:00:a4:39:ec  192.168.100.27 bond.idmqe.lab.eng.bos.redhat.com 	


eth1 	Interface
physical @ NAT foreman
52:54:00:d8:ed:67 192.168.100.121 bondhost1.idmqe.lab.eng.bos.redhat.com
Comment 12 Sachin Ghai 2016-04-20 09:35:55 EDT
however, If I check interfaces from console via ip addr cmd, all interfaces have same mac.

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master bond0 state UP qlen 1000
    link/ether 52:54:00:a4:39:ec brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5054:ff:fea4:39ec/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master bond0 state UP qlen 1000
    link/ether 52:54:00:a4:39:ec brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5054:ff:fea4:39ec/64 scope link 
       valid_lft forever preferred_lft forever
4: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 52:54:00:a4:39:ec brd ff:ff:ff:ff:ff:ff
    inet 192.168.100.27/24 brd 192.168.100.255 scope global dynamic bond0
       valid_lft 41727sec preferred_lft 41727sec
    inet6 fe80::5054:ff:fea4:39ec/64 scope link tentative dadfailed 
       valid_lft forever preferred_lft forever
Comment 13 Sachin Ghai 2016-04-20 09:36:33 EDT
here is the config of each interface:


[root@bondhost2 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
BOOTPROTO="none"
DEVICE=eth0
HWADDR="52:54:00:a4:39:ec"
ONBOOT=yes
PEERDNS=no
PEERROUTES=no
NM_CONTROLLED=no
MASTER=bond0
SLAVE=yes
[root@bondhost2 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1
BOOTPROTO="none"
DEVICE=eth1
HWADDR="52:54:00:d8:ed:67"
ONBOOT=yes
PEERDNS=no
PEERROUTES=no
NM_CONTROLLED=no
MASTER=bond0
SLAVE=yes
[root@bondhost2 ~]# cat /etc/sysconfig/network-scripts/ifcfg-bond0
BOOTPROTO="dhcp"
DEVICE=bond0
ONBOOT=yes
PEERDNS=no
PEERROUTES=no
DEFROUTE="yes"
TYPE=Bond
BONDING_OPTS="miimon=100 mode=balance-rr"
BONDING_MASTER=yes
NM_CONTROLLED=no
[root@bondhost2 ~]#
Comment 14 Sachin Ghai 2016-04-20 09:52:06 EDT
@Marek: Is it expected to have same mac for all interfaces when they are attached with bond interface as shown in comment12
Comment 15 Marek Hulan 2016-04-20 10:07:55 EDT
This seems expected, you can check real MAC addresses by

    cat /proc/net/bonding/bond0

You can find more information at https://access.redhat.com/solutions/130473
Comment 16 Sachin Ghai 2016-04-21 01:37:44 EDT
Thank you Marek.  I can see rel mac addresses with "cat /proc/net/bonding/bond0"

[root@bondhost2 ~]#  cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

Bonding Mode: load balancing (round-robin)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: eth0
MII Status: up
Speed: Unknown
Duplex: Unknown
Link Failure Count: 0
Permanent HW addr: 52:54:00:a4:39:ec
Slave queue ID: 0

Slave Interface: eth1
MII Status: up
Speed: Unknown
Duplex: Unknown
Link Failure Count: 0
Permanent HW addr: 52:54:00:d8:ed:67
Slave queue ID: 0


As per comment10 to 15, reported issue has been fixed. So moving this to verified.
Comment 18 errata-xmlrpc 2016-07-27 04:58:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.