Bug 1274444 - [RFE] support multipathed boot devices at deployment time
[RFE] support multipathed boot devices at deployment time
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: y2
: 7.0 (Kilo)
Assigned To: chris alfonso
nlevinki
: FutureFeature, OtherQA
: 1257903 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 13:58 EDT by David Critch
Modified: 2016-01-31 21:38 EST (History)
9 users (show)

See Also:
Fixed In Version: python-rdomanager-oscplugin-0.0.10-14.el7ost
Doc Type: Enhancement
Doc Text:
The Overcloud image is now multipath aware. This helps users aiming to deploy on nodes using a mutltipathed boot LUN. The operating system root is now mounted properly (e.g. /dev/mpatha).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:57:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 231690 None None None Never

  None (edit)
Description David Critch 2015-10-22 13:58:22 EDT
Description of problem:
The default RHEL guest image is not multipath aware at the time of install. If you are deploying OSP on a node with a mutltipathed boot LUN, the installer uses just one path and on startup, mounts e.g. /dev/sda, while it should use /dev/mpatha

Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.10-8.el7ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install OSP-d
2. Import and discover nodes that boot from a multipathed SAN LUN
3. Deploy overcloud

Actual results:
OS mounts / via /dev/sda1

Expected results:
OS mounts / via /dev/mpatha

Additional info:

I can work around it by following these steps: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/DM_Multipath/move_root_to_multipath.html

However it should be supported out of the box with no extra steps.
Comment 4 Mike Burns 2015-12-04 10:46:53 EST
*** Bug 1257903 has been marked as a duplicate of this bug. ***
Comment 5 nlevinki 2015-12-15 07:44:57 EST
Right now we don't have servers with multipath SAN LUN.
We have ony with disk installed and we don't have HBA or other card on them that will allow me to expose LUNs ad create another disk (i.e multipath).
Moving this ticket to OtherQA
Comment 7 errata-xmlrpc 2015-12-21 11:57:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.