Bug 1274445 - tuned-profiles-nfv: add nohz=on to the kernel command-line
tuned-profiles-nfv: add nohz=on to the kernel command-line
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
:
Depends On:
Blocks: kvm-rt-tuned 1273048
  Show dependency treegraph
 
Reported: 2015-10-22 13:59 EDT by Luiz Capitulino
Modified: 2015-11-03 09:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 09:38:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luiz Capitulino 2015-10-22 13:59:51 EDT
The RHEL real-time kernel is disabling nohz by default since kernel 3.10.0-320.rt56.196.el7 (bug 1206356), so we need to pass "nohz=on" in the host and guest profiles in order to enable it back.

Note that passing nozh_full= is not enough, we have to pass nohz_full= *and* nohz=on.
Comment 1 Jaroslav Škarvada 2015-10-29 11:18:14 EDT
Fixed trivially upstream by the following commit:
https://git.fedorahosted.org/cgit/tuned.git/commit/?id=9aeb585a636a5987cb5053317f4d9bb83d27f3fa

I will create nicer fix once the feature from bug 1274464 is ready.
Comment 2 Luiz Capitulino 2015-10-29 15:36:05 EDT
Thanks Jaroslav.

There's a discussion downstream about enabling nohz automagically when the kernel sees nohz_full= in the command-line. If this fix is implemented, then we don't have to rush with this on downstream (although it doesn't hurt having, in fact I think it's a good idea to have it because KVM-RT do depend on this feature).
Comment 3 Clark Williams 2015-10-29 16:26:36 EDT
Ah, Luiz beat me to it. I believe we'll have the nohz fix in 7.2 GA, presuming everything goes as planned. The fix is to to enable nohz if we see nohz_full while parsing/processing the boot command line. Bz for that one is 1274519.
Comment 4 Luiz Capitulino 2015-11-03 09:38:22 EST
The RHEL RT kernel got this issue fixed by enabling nohz when the kernel sees nohz_full= in the command-line (bug 1276071), so we don't need this fix anymore.

Jarda, sorry for making you fix this in upstream. You could revert the fix, as it's probably unusual to have nohz disabled by default. Or, you could leave it this way as it doesn't make any difference.

Note You need to log in before you can comment on or make changes to this bug.