Bug 1274453 - Need updated at-spi2-core package for GTK3 testing
Need updated at-spi2-core package for GTK3 testing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: at-spi2-core (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rui Matos
Desktop QE
: Rebase, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 14:28 EDT by Sean Toner
Modified: 2016-11-03 21:48 EDT (History)
7 users (show)

See Also:
Fixed In Version: at-spi2-core-2.14.1-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:48:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Toner 2015-10-22 14:28:58 EDT
Description of problem:
=======================

For subscription-manager-gui testing, we use a test tool called ldtp which uses pyatspi and the accessibility tool kit for automation testing.  The at-spi2-core package is a dependency for the high-level pyatspi package.

The version of at-spi2-core that exists in RHEL-7.2 is 2.8.0-6.el7 is about 3 years old and it is not current enough to support testing of certain GTK3 widgets (for example drop down boxes, spinner buttons, or key event presses).  This is causing a rather large portion of our automated tests to no longer work because of the GTK3 changes.

I have built the src.rpms from Fedora23 Beta on RHEL 7.2 and was able to get several GTK3 tests to work.  The version I built which works is 

[root@dhcp129-94 ~]# rpm -qa | grep at-spi2-core
at-spi2-core-devel-2.17.90-1.el7.x86_64
at-spi2-core-2.17.90-1.el7.x86_64
at-spi2-core-debuginfo-2.17.90-1.el7.x86_64

The latest version will be 2.18.0 I believe.


Version-Release number of selected component (if applicable):
=============================================================

2.8.0-6.el7

How reproducible:
=================

Always




Additional info:
================

There are 3 other packages which simultaneously need to be updated:

atk
at-spi2-atk
pyatspi
Comment 4 Matthias Clasen 2015-10-23 09:06:52 EDT
I don't think we can do a rebase at this point, less than a week from final devel freeze. This should have been brought up much earlier. We can certainly do this for 7.3
Comment 9 Bohdan Milar 2016-09-08 08:17:45 EDT
at-spi2-core autotests pass:
https://desktopqe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/beaker-at-spi2-core-RHEL-7.3/
Comment 11 errata-xmlrpc 2016-11-03 21:48:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2262.html

Note You need to log in before you can comment on or make changes to this bug.