Bug 1274484 - Update ConfigChannelHandler api doc to use sha256
Update ConfigChannelHandler api doc to use sha256
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
580
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Lukáš Hellebrandt
:
Depends On:
Blocks: sat580-low
  Show dependency treegraph
 
Reported: 2015-10-22 15:26 EDT by Shannon Hughes
Modified: 2017-06-21 08:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-21 08:18:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shannon Hughes 2015-10-22 15:26:04 EDT
Description of problem:

the config channel api now uses sha256 instead of md5. There are many references to md5 instead of sha256 in the sat webui docs for ConfigChannelHandler

satfqdn/rhn/apidoc/handlers/ConfigChannelHandler.jsp

Version-Release number of selected component (if applicable):

satellite 5.7
Comment 1 Jiri Precechtel 2016-04-06 04:27:48 EDT
- Information about usage of md5 was replaced by sha256 in ConfigRevisionSerializer macro.
- This change updates API doc for a few methods used in configchannel, system.config and system.provisioning.snapshot.
- Due to above change the name of "md5" key in ConfigRevision structure was replaced by "sha256".
- An above change had an impact to configchannel.py script which had to be updated too.

Spacewalk-git-commit: 7f317ee7f55379393b59d0b72ae13a76a13891cd

If the solution does not work for you, re-assign this bug please.
Comment 4 Lukáš Hellebrandt 2017-04-26 08:10:50 EDT
Verified with spacewalk-java-2.5.14-73 .

There are no mentions of MD5 in related pages anymore. It has been changed to SHA256. Changed calls in spacecmd work correctly.

Note You need to log in before you can comment on or make changes to this bug.