Bug 127450 - Resume failure on Dell Inspiron 8500
Summary: Resume failure on Dell Inspiron 8500
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-08 13:13 UTC by Simon Goodall
Modified: 2015-01-04 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 05:48:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results of lspci -v (4.95 KB, text/plain)
2004-07-08 13:14 UTC, Simon Goodall
no flags Details

Description Simon Goodall 2004-07-08 13:13:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
System hangs on resume from suspend (S1 or S3)

echo "1" > /proc/acpi/sleep

Final messages are:

Back to C!
PM: Finishing up.
PCI: Setting latency timer of device 0000:00:1d.0 to 64
PCI: Setting latency timer of device 0000:00:1d.1 to 64
PCI: Setting latency timer of device 0000:00:1d.2 to 64

Then complete freeze requiring a poweroff.


Version-Release number of selected component (if applicable):
kernel-2.6.6-1.435.2.3

How reproducible:
Always

Steps to Reproduce:
1. Boot into run level 3
2. Removed DriverLoader service / module
2. remove ehci_hcd and uhci_hcd modules
3. run: echo "1" > /proc/acpi/sleep
4. Press power button to resume
    

Actual Results:  Some initial output about usb device latency then
system freeze. console switching does not work, neither will caps lock
light.

Expected Results:  System should resume back to normal console.

Additional info:

I am using the latest kernel version (2.6.6-1.435.2.3 i686). I have
also tried the i586 version.
I have tried removing all the usb, network, firewire and pcmcia kernel
modules before suspending with no success.
I'm running the latest BIOS rev (A05)

Comment 1 Simon Goodall 2004-07-08 13:14:34 UTC
Created attachment 101721 [details]
Results of lspci -v

Comment 2 Simon Goodall 2004-09-20 11:05:57 UTC
Using the latest kernel (Kernel 2.6.8-1.521) + acpi patch (20040816) +
fixed dsdt tables (from acpi.souceforge.net), I am now able to
susupend and resume correctly from S1, and with S3 the system resumes,
but the display stays off.
This is in run level 3 with no framebuffer.

Comment 3 Dave Jones 2005-04-16 05:48:16 UTC
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.



Note You need to log in before you can comment on or make changes to this bug.