This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1274517 - koji fails with a TypeError doing a scratch build
koji fails with a TypeError doing a scratch build
Status: CLOSED DUPLICATE of bug 1186994
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 16:50 EDT by Tom Hughes
Modified: 2015-11-24 07:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 07:17:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Hughes 2015-10-22 16:50:22 EDT
Running a scratch build fails with a TypeError:

bericote [~] % koji --debug build --scratch rawhide rpm/SRPMS/nodejs-foreach-2.0.5-1.fc23.src.rpm
successfully connected to hub
Uploading srpm: rpm/SRPMS/nodejs-foreach-2.0.5-1.fc23.src.rpm
2015-10-22 21:46:00,215 [DEBUG] koji: Fast upload: rpm/SRPMS/nodejs-foreach-2.0.5-1.fc23.src.rpm to cli-build/1445546759.859138.McGduCNV/nodejs-foreach-2.0.5-1.fc23.src.rpm
2015-10-22 21:46:00,929 [DEBUG] koji: Fast upload: rpm/SRPMS/nodejs-foreach-2.0.5-1.fc23.src.rpm complete. 9862 bytes in 0.4 seconds

Created task: 11546927
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=11546927
Watching tasks (this may be safely interrupted)...
11546927 build (rawhide, nodejs-foreach-2.0.5-1.fc23.src.rpm): free
Traceback (most recent call last):
  File "/usr/bin/koji", line 6655, in <module>
    rv = locals()[command].__call__(options, session, args)
  File "/usr/bin/koji", line 952, in handle_build
    return watch_tasks(session, [task_id], quiet=build_opts.quiet)
  File "/usr/bin/koji", line 456, in watch_tasks
    changed = task.update()
  File "/usr/bin/koji", line 361, in update
    self.info = self.session.getTaskInfo(self.id, request=True)
  File "/usr/lib/python2.7/site-packages/koji/__init__.py", line 1577, in __call__
    return self.__func(self.__name,args,opts)
  File "/usr/lib/python2.7/site-packages/koji/__init__.py", line 1952, in _callMethod
    iter(arg)
TypeError: 'int' object is not iterable
Comment 1 Tom Hughes 2015-10-22 17:16:57 EDT
Should have said, the koji version is koji-1.10.0-2.fc23.noarch.
Comment 2 Lubomir Rintel 2015-11-24 07:17:43 EST
Same issue as bug #1186994, only the error reporting is broken. Patches for both issues there.

*** This bug has been marked as a duplicate of bug 1186994 ***

Note You need to log in before you can comment on or make changes to this bug.