This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 127454 - Scrolling in a maximised gnome-terminal produces line corruption
Scrolling in a maximised gnome-terminal produces line corruption
Status: CLOSED DUPLICATE of bug 104768
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-08 10:25 EDT by Sitsofe Wheeler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot showing line corruption (42.51 KB, image/png)
2004-07-08 10:34 EDT, Sitsofe Wheeler
no flags Details

  None (edit)
Description Sitsofe Wheeler 2004-07-08 10:25:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
Scrolling downwards in a maximised gnome-terminal somtimes causes the
top halves of lines not to be drawn.

Version-Release number of selected component (if applicable):
gnome-terminal-2.6.0-2

How reproducible:
Always

Steps to Reproduce:
1. Start gnome-termimal
2. Switch res to 640x480 (xrandr -s "640x480")
3. Maximise the gnome-terminal window
4. type dmesg<return>
5. Move the scrollbar to the top of the gnome-terminal
6. Move the scrollbar down quickly but do not let the scrollbar reach
the bottom

Actual Results:
Some lines are of text have only their bottom halves drawn

Expected Results:
Lines of text to always be fully formed

Additional info:
Corruption appears to only occur when dragging the scrollbar in a
downward direction. Corruption can also when using a mousewheel to
scroll and shift-pagedown  (although it is rarer).

Highlighting a single letter on a corrupted line causes ALL corrupted
lines to be redrawn properly. Parts of a corrupted line that are
obscured by another window are redrawn properly once exposed. This
problem can afflict any maximised gnome-terminal but is particularly
apparent for me at 640x480.

Could well be a dup of / related to bug 108194 although the
screenshots in that bug do not looks similar to the corruption I see.
Comment 1 Sitsofe Wheeler 2004-07-08 10:34:34 EDT
Created attachment 101722 [details]
Screenshot showing line corruption
Comment 2 Sitsofe Wheeler 2004-07-08 11:24:07 EDT
Known bug - http://bugzilla.gnome.org/show_bug.cgi?id=122150
Comment 3 Sitsofe Wheeler 2004-07-08 11:30:46 EDT
And it's already been reported to redhat bugzilla too - bug 104768 .
Sorry about that - I only searched for bugs in gnome-terminal... Next
time I'll do a search by a single word in the description on all
components.
Comment 4 Miloslav Trmac 2004-07-08 12:53:22 EDT

*** This bug has been marked as a duplicate of 104768 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:04:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.