Bug 1274609 - tuned-gui fails when creating new profile
Summary: tuned-gui fails when creating new profile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Tereza Cerna
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-23 06:57 UTC by ilmostro7
Modified: 2016-11-04 07:26 UTC (History)
4 users (show)

Fixed In Version: tuned-2.7.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:26:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2479 normal SHIPPED_LIVE tuned bug fix and enhancement update 2016-11-03 14:08:42 UTC

Description ilmostro7 2015-10-23 06:57:27 UTC
Description of problem:
tuned-gtk fails to create a new profile when a user tries to do so according
to the program's UI.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. launch tuned-gui from commandline and enter password when prompted
2. click on "create new" under profiles
3. make changes, if any, click confirm

Actual results:
Traceback (most recent call last):
  File "/usr/sbin/tuned-gui", line 643, in on_click_button_confirm_profile_create
    self.manager.save_profile(prof)
  File "/usr/lib/python2.7/site-packages/tuned/gtk/gui_profile_loader.py", line 102, in save_profile
    config.filename = path + tuned.consts.CONF_PROFILE_FILE
AttributeError: 'module' object has no attribute 'CONF_PROFILE_FILE'
Traceback (most recent call last):
  File "/usr/sbin/tuned-gui", line 643, in on_click_button_confirm_profile_create
    self.manager.save_profile(prof)
  File "/usr/lib/python2.7/site-packages/tuned/gtk/gui_profile_loader.py", line 102, in save_profile
    config.filename = path + tuned.consts.CONF_PROFILE_FILE
AttributeError: 'module' object has no attribute 'CONF_PROFILE_FILE'
Traceback (most recent call last):
  File "/usr/sbin/tuned-gui", line 643, in on_click_button_confirm_profile_create
    self.manager.save_profile(prof)
  File "/usr/lib/python2.7/site-packages/tuned/gtk/gui_profile_loader.py", line 102, in save_profile
    config.filename = path + tuned.consts.CONF_PROFILE_FILE
AttributeError: 'module' object has no attribute 'CONF_PROFILE_FILE'

Expected results:

clicking "Confirm" should create a new profile
Additional info:

These were the items installed on the system: 

# rpm -qa |grep -i tuned
tuned-gtk-2.5.1-1.el7.noarch
tuned-2.5.1-1.el7.noarch

# yum list tuned\*
Installed Packages
tuned.noarch                                                                                                    2.5.1-1.el7                                                                                   @rhel-7-server-beta-rpms         
tuned-gtk.noarch                                                                                                2.5.1-1.el7                                                                                   @rhel-7-server-optional-beta-rpms
Available Packages
tuned-profiles-atomic.noarch                                                                                    2.5.1-1.el7                                                                                   rhel-7-server-optional-beta-rpms 
tuned-profiles-compat.noarch                                                                                    2.5.1-1.el7                                                                                   rhel-7-server-optional-beta-rpms 
tuned-profiles-oracle.noarch                                                                                    2.5.1-1.el7                                                                                   rhel-7-server-optional-beta-rpms 
tuned-profiles-realtime.noarch                                                                                  2.5.1-1.el7                                                                                   rhel-7-server-rt-beta-rpms       
tuned-utils.noarch                                                                                              2.5.1-1.el7                                                                                   rhel-7-server-beta-rpms          
tuned-utils-systemtap.noarch                                                                                    2.5.1-1.el7                                                                                   rhel-7-server-optional-beta-rpms

Comment 2 Jaroslav Škarvada 2015-10-27 16:58:01 UTC
Thanks for the report, fixed by upstream commit:
https://git.fedorahosted.org/cgit/tuned.git/commit/?id=b26327d572dadff9dfa0ed87431a597f93bbb703

Comment 5 Tereza Cerna 2016-08-09 13:43:03 UTC
================================
Verified in:
    tuned-2.7.1-1.el7.noarch
    tuned-gtk-2.7.1-1.el7.noarch
PASS
================================

$ tuned-gui
    
    1. Enter password
    2. Click on 'create new' under tab profiles
    3. Fill some name and several values and confirm
          name: test
          reset_controller: True  (plugin audio)
          timeout: 5              (plugin audio)
    4. Check new profile in list of all profiles
    5. Activate test profile -> WORKING
    6. Exit application

$ tuned-adm active
Current active profile: test

$ tuned-adm verify
Verfication succeeded, current system settings match the preset profile.
See tuned log file ('/var/log/tuned/tuned.log') for details.

$ cat /etc/tuned/test/tuned.conf 
[main]
[audio]
reset_controller = True
timeout = 5

================================
Reproduced in:
  tuned-gtk-2.5.1-4.el7.noarch
  tuned-2.5.1-4.el7.noarch       
FAIL
================================

Traceback appeared when I confirm creation of new profile:

Traceback (most recent call last):
  File "/usr/sbin/tuned-gui", line 643, in on_click_button_confirm_profile_create
    self.manager.save_profile(prof)
  File "/usr/lib/python2.7/site-packages/tuned/gtk/gui_profile_loader.py", line 102, in save_profile
    config.filename = path + tuned.consts.CONF_PROFILE_FILE
AttributeError: 'module' object has no attribute 'CONF_PROFILE_FILE'

Comment 7 errata-xmlrpc 2016-11-04 07:26:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2479.html


Note You need to log in before you can comment on or make changes to this bug.