Bug 1274610 - Unable to partition SSD and SATA HDD prior to installation
Unable to partition SSD and SATA HDD prior to installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 02:59 EDT by Dave P
Modified: 2015-10-26 09:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-23 04:50:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave P 2015-10-23 02:59:20 EDT
Description of problem:
I have 256G SSD, 1TB HDD. I want to partition them either in one operation or as two stages, to allocate major directories as I see fit. 


Version-Release number of selected component (if applicable):
Current

How reproducible:
Try to partition 'part' of minimum requirement on one drive, then 
partition the other. #fails

Steps to Reproduce:
1. Fail to create / partition on SSD
2. Try to create / on SATA HDD
3.

Actual results: Anaconda reports an error, will not allow restart,
basically have to shut down the install. 


Expected results: I would like to allocate all required partitions to one of n disks such that the total satisfies Anaconda, not all on one disk. 


Additional info: I believe that SSD's are sufficiently low in price / common that this requirement will increase.
Comment 1 Dave P 2015-10-23 04:50:48 EDT
Problem solved.

I find Anaconda so archaic and difficult to drive. It has taken me three days to find out how to do this.

Even then 'only if you drive it as the devs thought it should'?

Please make it easier for less experienced / patient users. 

For anyone else.


# SSD + SATA setup, Fedora 22

Issue: The Anaconda interface makes it difficult to partition two
disks at one session.

Requirement: To allocate partititions to either one of two (or more?)
disks, the only final constraint being that Anaconda is satisfied that
all required partitions are present.

Resolution: Drive Anaconda to satisfy its interface constraints,
i.e. it won't work unless you sequence your actions appropriately.

Pre-conditions:

1. The SSD was already partitioned using gdisk, according to the GPT
   system.
2. The HDD was not formatted / partitioned.
3. BIOS was set to boot using UEFI from the Fedora 22 boot DVD

Check the boot screen indicates booting using UEFI since the DVD can
boot in either mode.

Once into Anaconda, enter the partitioning screens, having selected
both disks for the target installation by clicking on them both -
select done. This goes to the screen which defines the partitions.

Ensure that 'I will configure partitioning' is ticked.

At the bottom of the partition area, an 'unknown' indicates that
something was found on the SSD. I had already created sized partitions
for /boot /usr /boot/efi and the remainder was just spare.

These were identified as sda1..4 and the size indicated my intended
use. Getting from there to a partition was the delicate part.


First assign the already created partitions to the right disk etc.

Select  a partition (e.g. sda1 )

Ensure that the 'Device' top right is showing the SSD, not the hdd. I really don't know how this 'choice' is supposed to work.


1. On the right half of the screen, tick the 'reformat' box. This enables other, currently grayed out areas to be filled in.
2. Select the File system (ext4 etc, as appropriate)
3. You are now allowed to fill in the mount point.

The 'desired capacity' should already be set from the previous work.

Repeat this for the other already partitioned areas of the SSD.

That provides (in my case) all partitions except swap and root (/ )
which I wanted on the HDD.

To create these two, firstly use the plus sign (bottom left) to
add/create a partition. In my case I added /, max space, ext4. to the
list of partitions. Except... The disk seems wrong. I was now able to
use the Devices box to change the device on which the partition is
created.

Repeat this for any other partitions you want on the HDD.

Selecting done now should not reveal any errors.

Having done that, I was allowed to complete the installation of Fedora
22 and hope to be able to repeat for Fedora 23.

The only issue I  had when I booted the new system was a reported error,

'Oops /usr/libexec/Xorg has crashed'

I continued and the system appeared quite robust.

I will test it out more completely when I install Fedora 23.

Note You need to log in before you can comment on or make changes to this bug.