Bug 1274626 - Remove selinux mount option from "man mount.glusterfs"
Remove selinux mount option from "man mount.glusterfs"
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: hari gowtham
:
Depends On: 1269885
Blocks: 1269887 1281226
  Show dependency treegraph
 
Reported: 2015-10-23 03:35 EDT by hari gowtham
Modified: 2016-06-16 09:40 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1269885
: 1281226 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:40:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-10-26 02:41:18 EDT
REVIEW: http://review.gluster.org/12422 (Remove selinux mount option from "man mount.glusterfs") posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2015-10-27 02:04:02 EDT
REVIEW: http://review.gluster.org/12422 (Remove selinux mount option from "man mount.glusterfs") posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2015-10-28 09:03:48 EDT
REVIEW: http://review.gluster.org/12422 (Remove selinux mount option from "man mount.glusterfs") posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Vijay Bellur 2015-10-29 01:17:29 EDT
REVIEW: http://review.gluster.org/12422 (Remove selinux mount option from "man mount.glusterfs") posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Vijay Bellur 2015-10-30 01:26:02 EDT
REVIEW: http://review.gluster.org/12422 (Remove selinux mount option from "man mount.glusterfs") posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 6 Vijay Bellur 2015-11-02 04:55:56 EST
REVIEW: http://review.gluster.org/12422 (Remove selinux mount option from "man mount.glusterfs") posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 7 Vijay Bellur 2015-11-03 01:29:52 EST
REVIEW: http://review.gluster.org/12422 (Remove selinux mount option from "man mount.glusterfs") posted (#7) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 8 Vijay Bellur 2015-11-03 04:40:49 EST
REVIEW: http://review.gluster.org/12422 (Remove selinux mount option from "man mount.glusterfs") posted (#8) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 9 Vijay Bellur 2015-11-10 10:11:33 EST
COMMIT: http://review.gluster.org/12422 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit a02cb725c7fd0d8fbc94d7d815fdf5494815ac93
Author: hari gowtham <hgowtham@redhat.com>
Date:   Mon Oct 26 12:07:16 2015 +0530

    Remove selinux mount option from "man mount.glusterfs"
    
    Gluster doesn't SELinux mount option, so it is removed.
    
    Change-Id: I471ad98a24b5f5d64279c805b3243cb1168dd3d1
    BUG: 1274626
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/12422
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 10 Vijay Bellur 2015-11-10 10:19:15 EST
Description of problem:

Remove selinux mount option from "man mount.glusterfs"
As we do not support this, it should be removed from the man page.

# man mount.glusterfs

...
       selinux
              Enable SELinux label (extened attributes) support on inodes
...

...
/etc/fstab
              A typical GlusterFS entry in /etc/fstab looks  like
              below

              server1:/mirror     /mnt/mirror    glusterfs   log-
              file=/var/log/mirror.log,acl,selinux   0  0
...                                            |__to be even rectified
Comment 11 Vijay Bellur 2015-11-12 00:29:16 EST
REVIEW: http://review.gluster.org/12572 (Remove selinux mount option from "man mount.glusterfs") posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 12 Niels de Vos 2016-06-16 09:40:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.