Bug 1274662 - AttributeError: 'Namespace' object has no attribute 'pulp'
AttributeError: 'Namespace' object has no attribute 'pulp'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 06:06 EDT by Alex Jia
Modified: 2016-03-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:25:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Jia 2015-10-23 06:06:28 EDT
Description of problem:
The atomic upload command is a aliase of push command now, but in fact, it doesn't work well, you will get error "AttributeError: 'Namespace' object has no attribute 'pulp'" when run atomic upload.


Version-Release number of selected component (if applicable):
# rpm -q atomic 
atomic-1.6-1.gitca1e384.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. atomic upload

Actual results:

[root@dell-per630-02 atomic]# atomic upload
Traceback (most recent call last):
  File "/usr/bin/atomic", line 420, in <module>
    sys.exit(args.func())
  File "/usr/lib/python2.7/site-packages/Atomic/atomic.py", line 155, in push
    if self.args.pulp:
AttributeError: 'Namespace' object has no attribute 'pulp'

Expected results:

Atomic upload command works well like push command.

Additional info:

# cat atomic

<slice>
    # atomic push
    pushp = subparser.add_parser(
        "push", aliases=['upload'], help=_("push latest image to repository"),
        epilog="push the latest specified image to a repository.")
    pushp.set_defaults(func=atomic.push)

    # atomic push
    pushp = subparser.add_parser(
        "push", help=_("push latest image to repository"),
        epilog="atomic push uploads the latest specified image.")
    pushp.set_defaults(func=atomic.push)
</slice>
Comment 1 Alex Jia 2015-10-23 06:09:09 EDT
I committed a PR to fix atrribute error https://github.com/projectatomic/atomic/pull/193, but we also need to add command options to upload like push commands.

optional arguments:
  -h, --help            show this help message and exit
  --pulp                push image using pulp
  --satellite           push image using Satellite
  --verify_ssl          flag to verify ssl of registry
  --debug               debug mode
  -U URL, --url URL     URL for remote registry
  -u USERNAME, --username USERNAME
                        Username for remote registry
  -p PASSWORD, --password PASSWORD
                        Password for remote registry
  -a ACTIVATION_KEY, --activation_key ACTIVATION_KEY
                        Activation Key
  -r REPO_ID, --repository_id REPO_ID
                        Repository ID
Comment 3 Daniel Walsh 2015-10-28 09:49:38 EDT
Fixed in atomic-1.5
Comment 5 Alex Jia 2016-01-20 05:32:01 EST
Atomic upload w/o 'AttributeError' on atomic-1.8-2.gita35ae18.el7.x86_64, so move the bug to VERIFIED status.
Comment 7 errata-xmlrpc 2016-03-31 19:25:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0527.html

Note You need to log in before you can comment on or make changes to this bug.