Bug 1274663 - <NameError>: <uninitialized constant MiqAeMethodService::MiqAeServiceManageIQ_Providers_Openstack_CloudManager_CloudTenant> when navigated to heat stack order service page.
<NameError>: <uninitialized constant MiqAeMethodService::MiqAeServiceManageIQ...
Status: CLOSED DUPLICATE of bug 1275405
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.5.0
Assigned To: Bill Wei
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 06:11 EDT by Aziza Karol
Modified: 2015-11-11 15:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 12:01:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2015-10-23 06:11:14 EDT
Description of problem:


Version-Release number of selected component (if applicable):
5.5.0.7

How reproducible:
100%

Steps to Reproduce:
1.create a catalog item to deploy heat stack for openstack provider
2.Navigate to all services and click on order button
3.

Actual results:
ERROR -- : MiqAeServiceModelBase.ar_method raised: <NameError>: <uninitialized constant MiqAeMethodService::MiqAeServiceManageIQ_Providers_Openstack_CloudManager_CloudTenant> in logs

Expected results:


Additional info:
automation.log
[----] I, [2015-10-23T06:09:21.033625 #2937:e9f994]  INFO -- : Instantiating [/Cloud/Orchestration/Operations/Methods/Available_Tenants?MiqServer%3A%3Amiq_server=2&ServiceTemplate%3A%3Aservice_template=2&User%3A%3Auser=1&object_name=Available_Tenants&vmdb_object_type=service_template]
[----] I, [2015-10-23T06:09:21.055645 #2937:e9f994]  INFO -- : Updated namespace [/Cloud/Orchestration/Operations/Methods/Available_Tenants?MiqServer%3A%3Amiq_server=2&ServiceTemplate%3A%3Aservice_template=2&User%3A%3Auser=1&object_name=Available_Tenants&vmdb_object_type=service_template  ManageIQ/Cloud/Orchestration/Operations]
[----] I, [2015-10-23T06:09:21.095484 #2937:e9f994]  INFO -- : Updated namespace [Cloud/Orchestration/Operations/Methods/available_tenants  ManageIQ/Cloud/Orchestration/Operations]
[----] I, [2015-10-23T06:09:21.099654 #2937:e9f994]  INFO -- : Invoking [inline] method [/ManageIQ/Cloud/Orchestration/Operations/Methods/Available_Tenants] with inputs [{}]
[----] I, [2015-10-23T06:09:21.100431 #2937:e9f994]  INFO -- : <AEMethod [/ManageIQ/Cloud/Orchestration/Operations/Methods/Available_Tenants]> Starting 
[----] E, [2015-10-23T06:09:21.536524 #2937:6f8216c] ERROR -- : MiqAeServiceModelBase.ar_method raised: <NameError>: <uninitialized constant MiqAeMethodService::MiqAeServiceManageIQ_Providers_Openstack_CloudManager_CloudTenant>
[----] E, [2015-10-23T06:09:21.536643 #2937:6f8216c] ERROR -- : /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:116:in `const_get'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:116:in `block in wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:261:in `ar_method'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:108:in `wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `block (2 levels) in wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `collect'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `block in wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:261:in `ar_method'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:108:in `wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:126:in `wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:97:in `block (2 levels) in expose'
/opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1624:in `perform_without_block'
/opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1584:in `perform'
/opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1657:in `block (2 levels) in main_loop'
/opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1653:in `loop'
/opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1653:in `block in main_loop'
[----] E, [2015-10-23T06:09:21.536768 #2937:6f8216c] ERROR -- : MiqAeServiceModelBase.ar_method raised: <NameError>: <uninitialized constant MiqAeMethodService::MiqAeServiceManageIQ_Providers_Openstack_CloudManager_CloudTenant>
[----] E, [2015-10-23T06:09:21.536850 #2937:6f8216c] ERROR -- : /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:116:in `const_get'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:116:in `block in wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:261:in `ar_method'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:108:in `wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `block (2 levels) in wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `collect'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `block in wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:261:in `ar_method'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:108:in `wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:126:in `wrap_results'
/var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:97:in `block (2 levels) in expose'
/opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1624:in `perform_without_block'
/opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1584:in `perform'
/opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1657:in `block (2 levels) in main_loop'
/opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1653:in `loop'
/opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1653:in `block in main_loop'
[----] E, [2015-10-23T06:09:21.539182 #2937:65f96a4] ERROR -- : <AEMethod available_tenants> The following error occurred during method evaluation:
[----] E, [2015-10-23T06:09:21.539757 #2937:65f96a4] ERROR -- : <AEMethod available_tenants>   NameError: uninitialized constant MiqAeMethodService::MiqAeServiceManageIQ_Providers_Openstack_CloudManager_CloudTenant
[----] E, [2015-10-23T06:09:21.540888 #2937:65f96a4] ERROR -- : <AEMethod available_tenants>   (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:116:in `const_get'
(druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:116:in `block in wrap_results'
(druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:261:in `ar_method'
(druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:108:in `wrap_results'
(druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `block (2 levels) in wrap_results'
(druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `collect'
(druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `block in wrap_results'
(druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:261:in `ar_method'
(druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:108:in `wrap_results'
(druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:126:in `wrap_results'
(druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:97:in `block (2 levels) in expose'
(druby://127.0.0.1:44153) /opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1624:in `perform_without_block'
(druby://127.0.0.1:44153) /opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1584:in `perform'
(druby://127.0.0.1:44153) /opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1657:in `block (2 levels) in main_loop'
(druby://127.0.0.1:44153) /opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1653:in `loop'
(druby://127.0.0.1:44153) /opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1653:in `block in main_loop'
[----] E, [2015-10-23T06:09:21.542954 #2937:6f826a8] ERROR -- : Method STDERR: (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:116:in `const_get': uninitialized constant MiqAeMethodService::MiqAeServiceManageIQ_Providers_Openstack_CloudManager_CloudTenant (NameError)
[----] E, [2015-10-23T06:09:21.543069 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:116:in `block in wrap_results'
[----] E, [2015-10-23T06:09:21.543156 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:261:in `ar_method'
[----] E, [2015-10-23T06:09:21.543279 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:108:in `wrap_results'
[----] E, [2015-10-23T06:09:21.543376 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `block (2 levels) in wrap_results'
[----] E, [2015-10-23T06:09:21.543473 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `collect'
[----] E, [2015-10-23T06:09:21.543567 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:112:in `block in wrap_results'
[----] E, [2015-10-23T06:09:21.543677 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:261:in `ar_method'
[----] E, [2015-10-23T06:09:21.543774 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:108:in `wrap_results'
[----] E, [2015-10-23T06:09:21.543872 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:126:in `wrap_results'
[----] E, [2015-10-23T06:09:21.543972 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:97:in `block (2 levels) in expose'
[----] E, [2015-10-23T06:09:21.544082 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1624:in `perform_without_block'
[----] E, [2015-10-23T06:09:21.544217 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1584:in `perform'
[----] E, [2015-10-23T06:09:21.544330 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1657:in `block (2 levels) in main_loop'
[----] E, [2015-10-23T06:09:21.544428 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1653:in `loop'
[----] E, [2015-10-23T06:09:21.544533 #2937:6f826a8] ERROR -- : Method STDERR: 	from (druby://127.0.0.1:44153) /opt/rh/rh-ruby22/root/usr/share/ruby/drb/drb.rb:1653:in `block in main_loop'
[----] E, [2015-10-23T06:09:21.544627 #2937:6f826a8] ERROR -- : Method STDERR: 	from <code: service_template.orchestration_manager.cloud_tenants.each { |t| tenant_list[t.name] = t.name }>:7:in `<main>'
[----] I, [2015-10-23T06:09:21.555608 #2937:e9f994]  INFO -- : <AEMethod [/ManageIQ/Cloud/Orchestration/Operations/Methods/Available_Tenants]> Ending
[----] E, [2015-10-23T06:09:21.555927 #2937:e9f994] ERROR -- : Aborting instantiation (unknown method return code) because [Method exited with rc=Unknown RC: [1]]
[----] I, [2015-10-23T06:09:23.646911 #2913:6a9988]  INFO -- : Instantiating [/System/Process/Event?EventStream%3A%3Aevent_stream=1644&ExtManagementSystem%3A%3Aems=1&MiqServer%3A%3Amiq_server=2&User%3A%3Auser=1&ems_id=1&event_id=1644&event_type=UserLoginSessionEvent&object_name=Event&vmdb_object_type=event_stream]
Comment 2 Bill Wei 2015-10-29 12:01:49 EDT
Even though the symptom is different, but the root cause is the same. This bug is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1275405.

*** This bug has been marked as a duplicate of bug 1275405 ***

Note You need to log in before you can comment on or make changes to this bug.