Bug 1274688 - Compare of two different version of one Contenview doesn't show any difference
Compare of two different version of one Contenview doesn't show any difference
Status: CLOSED DUPLICATE of bug 1212450
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
6.1.2
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Ohad Levy
Katello QA List
: Triaged
Depends On:
Blocks: 1317008
  Show dependency treegraph
 
Reported: 2015-10-23 07:33 EDT by Marcel Gazdík
Modified: 2017-04-25 12:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-09 17:14:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2162221 None None None 2016-02-15 12:02 EST

  None (edit)
Description Marcel Gazdík 2015-10-23 07:33:37 EDT
Description of problem:
  In the content page, there is possible to compare two different versions of one content view. However, the result is always wrong, as it shows the same amount of packages/erratas in both columns. Moreover, if you add a repository into a CV, then the link "Show 25 More" doesn't work and if you click on it, then you receive a message "Couldn't find Katello::KTEnvironment without an ID".

Version-Release number of selected component (if applicable):
6.1.2

How reproducible + steps to Reproduce:
1) Create a content view, add repository and publish it. Next add another repository and publish new version. Promote the new version to another Lifecycle environment afterwards, 

2) Go to Content -> Content Search,

3) Click on search,

4) Add another lifecycle environment using the plus button in the top right corner of the table with compare results,

5) Select the content view versions and click on "Compare selected",

6) You should be able to see two columns comparing the versions.

7) To see the error message mentioned above click on the repository, scroll down and click on the "Show 25 More" link.

Actual results:
The comparison shows no difference between the versions 

Expected results:
There will be visible differences in the comparison

Additional info:
  Possible related BZ: 
    #1212450
    #1262371
    #1241500
Comment 5 Bryan Kearney 2016-07-08 16:23:42 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 7 Brad Buckingham 2016-08-09 17:14:39 EDT
Content search was removed in Satellite 6.2; however, there is a bugzilla tracking the need to provide comparison of content view versions.  I am going to close this one as a duplicate of it, so that the requests can be tracked together.

*** This bug has been marked as a duplicate of bug 1212450 ***

Note You need to log in before you can comment on or make changes to this bug.