Bug 1274697 - zsh in ksh emulation mode, coredumps when trying to check the syntax of a shell script
zsh in ksh emulation mode, coredumps when trying to check the syntax of a she...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: zsh (Show other bugs)
7.0
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Kamil Dudka
Branislav Náter
: Patch, ZStream
Depends On: 1222867
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 08:04 EDT by Jan Kurik
Modified: 2015-11-04 09:28 EST (History)
8 users (show)

See Also:
Fixed In Version: zsh-5.0.2-7.el7_1.2
Doc Type: Bug Fix
Doc Text:
Previously, the code that initializes environment variables in zsh did not correctly handle NULL values. As a consequence, zsh terminated unexpectedly when attempting to check the syntax of a shell script in ksh emulation mode. This update fixes the handling of NULL values, and the syntax check now works as expected when zsh runs in ksh emulation mode.
Story Points: ---
Clone Of: 1222867
Environment:
Last Closed: 2015-11-04 09:28:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-10-23 08:04:28 EDT
This bug has been copied from bug #1222867 and has been proposed
to be backported to 7.1 z-stream (EUS).
Comment 8 errata-xmlrpc 2015-11-04 09:28:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1964.html

Note You need to log in before you can comment on or make changes to this bug.