This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1274698 - zsh wait builtin does not work for already exited processes [RHEL-7]
zsh wait builtin does not work for already exited processes [RHEL-7]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: zsh (Show other bugs)
7.0
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Kamil Dudka
Branislav Náter
: Patch, Reopened, ZStream
Depends On: 1150554
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 08:05 EDT by Jan Kurik
Modified: 2015-11-04 09:29 EST (History)
10 users (show)

See Also:
Fixed In Version: zsh-5.0.2-7.el7_1.2
Doc Type: Enhancement
Doc Text:
With this update, the "wait" built-in command of zsh can now wait for (and obtain the exit status of) any selected background process, which no longer needs to be the latest created one.
Story Points: ---
Clone Of: 1150554
Environment:
Last Closed: 2015-11-04 09:29:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-10-23 08:05:17 EDT
This bug has been copied from bug #1150554 and has been proposed
to be backported to 7.1 z-stream (EUS).
Comment 8 errata-xmlrpc 2015-11-04 09:29:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1964.html

Note You need to log in before you can comment on or make changes to this bug.