Bug 1274717 - [z-stream clone 3.5.6] Vm becomes unusable (NPE) when restarting vdsm during snapshot creation
[z-stream clone 3.5.6] Vm becomes unusable (NPE) when restarting vdsm during ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.3
Unspecified Unspecified
high Severity high
: ovirt-3.5.6
: 3.5.6
Assigned To: Shmuel Melamud
Ilanit Stein
virt
: ZStream
Depends On: 1236061
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 08:24 EDT by rhev-integ
Modified: 2016-02-10 14:23 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1236061
Environment:
Last Closed: 2015-12-01 14:06:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 43863 master MERGED core: Compensation of active snapshot ID change Never
oVirt gerrit 45479 ovirt-engine-3.6 MERGED core: Compensation of active snapshot ID change Never
oVirt gerrit 47750 ovirt-engine-3.5 MERGED core: Compensation of active snapshot ID change Never

  None (edit)
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-27 07:55:50 EDT
Fixed bug tickets must have target milestone set prior to fixing them. Please set the correct milestone and move the bugs back to the previous status after this is corrected.
Comment 3 Ilanit Stein 2015-11-01 07:57:14 EST
Verified on vt18 (3.5.6).

Followed the scenario in the description:
1. Create a vm with multiple disks of different types
2. Add a snapshot to the vm (all disks)
3. when the engine.log shows the CreateAllSnapshotsFromVmCommand, restart the vdsm in the spm host

Snapshot that was created at step 2. finished successfully.
VM create snapshot afterwards worked OK.
VM run worked OK.
Comment 5 errata-xmlrpc 2015-12-01 14:06:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2531.html

Note You need to log in before you can comment on or make changes to this bug.