Bug 1274727 - Some files not collected by powerpc plugin because of missing commas
Some files not collected by powerpc plugin because of missing commas
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos (Show other bugs)
7.1
ppc64le Linux
urgent Severity urgent
: rc
: 7.3
Assigned To: Pavel Moravec
Miroslav Hradílek
: Patch
: 1282482 (view as bug list)
Depends On:
Blocks: 1230910 1276040 1295396 1364088
  Show dependency treegraph
 
Reported: 2015-10-23 09:01 EDT by Martin Frodl
Modified: 2016-11-04 00:55 EDT (History)
11 users (show)

See Also:
Fixed In Version: sos-3.3-0.el7
Doc Type: Bug Fix
Doc Text:
Prior to this update, the powerpc plug-in for the sos utility did not collect several commands output due to a typo in their invocation. With this update, the typo has been fixed and the commands are newly collected.
Story Points: ---
Clone Of:
: 1274729 (view as bug list)
Environment:
Last Closed: 2016-11-04 00:55:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[powerpc] Fix files to copy list delimiter (2.08 KB, patch)
2015-11-17 05:48 EST, IBM Bug Proxy
no flags Details | Diff

  None (edit)
Description Martin Frodl 2015-10-23 09:01:58 EDT
Description of problem:

In sosreport's powerpc plugin, two lines with paths to be collected are not terminated by a comma, which causes them to merge together into a nonsensical string. As a result, the corresponding files are not collected:

            self.add_copy_spec([
                "/proc/ppc64/eeh",
                "/proc/ppc64/systemcfg"
                "/proc/ppc64/topology_updates"
                "/sys/firmware/opal/msglog",
                "/var/log/opal-elog/"
            ])

Version-Release number of selected component (if applicable):
sos-3.2-15.el7_1.8.noarch
Comment 1 Bryn M. Reeves 2015-11-16 12:47:01 EST
*** Bug 1282482 has been marked as a duplicate of this bug. ***
Comment 2 Hanns-Joachim Uhl 2015-11-17 02:59:11 EST
fyi .. from RHBZ 1282482 - sosreport: Fix sysfile data collection for msglog (running bare-metal on POWER8):
"
... this patch has been posted upstream 
https://www.redhat.com/archives/sos-devel/2015-October/msg00004.html  ...
"
...
Comment 3 IBM Bug Proxy 2015-11-17 05:48:12 EST
Created attachment 1095328 [details]
[powerpc] Fix files to copy list delimiter
Comment 4 Pavel Moravec 2015-12-19 10:51:50 EST
POSTed to upstream as commit ce1af8e84a479b10960eb421340fdd8df60ffd29
Comment 6 Mike McCune 2016-03-28 19:20:28 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 IBM Bug Proxy 2016-08-22 10:51:02 EDT
------- Comment From hegdevasant@in.ibm.com 2016-08-22 10:46 EDT-------
[root@ltc-garri2 ~]# sosreport
sosreport (version 3.3)
This command will collect diagnostic and configuration information from
this Red Hat Enterprise Linux system and installed applications.
An archive containing the collected information will be generated in
representative.
Any information provided to Red Hat will be treated in accordance with
the published support policies at:
https://access.redhat.com/support/
The generated archive may contain data considered sensitive and its
content should be reviewed by the originating organization before being
passed to any third party.
No changes will be made to system configuration.
Press ENTER to continue, or CTRL-C to quit.
Please enter your first initial and last name [ltc-garri2.aus.stglabs.ibm.com]:
Please enter the case id that you are generating this report for []:
Setting up archive ...
Setting up plugins ...
Running plugins. Please wait ...
Running 27/86: ipmitool...
[plugin:ipmitool] command 'ipmitool sensor list' timed out after 300s
[plugin:ipmitool] command 'ipmitool fru print' timed out after 300s
Running 59/86: powerpc...
[plugin:powerpc] command 'lsmcode -A' timed out after 300s
Running 86/86: yum...              ...
Creating compressed archive...
Your sosreport has been generated and saved in:
/var/tmp/sosreport-ltc-garri2.aus.stglabs.ibm.com-20160822052520.tar.xz
The checksum is: d624e3d894fd612ce644f5dabf291f71
Please send this file to your support representative.

[root@ltc-garri2 sosreport-ltc-garri2.aus.stglabs.ibm.com-20160822052520]# find ./ -iname 'opal-elog'
[root@ltc-garri2 sosreport-ltc-garri2.aus.stglabs.ibm.com-20160822052520]# cat proc/ppc64/systemcfg
b]?7????????????????????????????????????????????????????????????????????????????????????????????[root@ltc-garri2 sosreport-ltc-garri2.aus.stglabs.ibm.com-20160822052520]#
[root@ltc-garri2 sosreport-ltc-garri2.aus.stglabs.ibm.com-20160822052520]#
[root@ltc-garri2 sosreport-ltc-garri2.aus.stglabs.ibm.com-20160822052520]# cat proc/ppc64/topology_updates
off
[root@ltc-garri2 sosreport-ltc-garri2.aus.stglabs.ibm.com-20160822052520]# ls sys/firmware/opal/msglog  -l
-r--r--r--. 1 root root 304381 Aug 21 01:57 sys/firmware/opal/msglog

As we can see the files are being collected.
So this bugzilla is resolved.

-Mukesh
Comment 11 errata-xmlrpc 2016-11-04 00:55:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2380.html

Note You need to log in before you can comment on or make changes to this bug.