Bug 1274750 - In the undercloud Nova's ram_allocation_ratio configuration option should be set to "1.0"
In the undercloud Nova's ram_allocation_ratio configuration option should be ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Lucas Alvares Gomes
Joe H. Rahme
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 09:42 EDT by Lucas Alvares Gomes
Modified: 2016-04-07 17:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: instack-undercloud-2.2.2-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:41:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 255821 None None None Never

  None (edit)
Description Lucas Alvares Gomes 2015-10-23 09:42:42 EDT
Description of problem:
By default the Nova's "ram_allocation_ratio" is "1.5", this doesn't make sense for baremetal because we can't allocate more memory than the machine already has.

By leaving it as default ("1.5") will cause scheduling instances to fail in case the amount of RAM in the node's is exactly the same size in the flavor. And this should just work.


Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Create a flavor that requires 512MB of memory
2. Create a node (and have only one node available) in ironic that has 512MB of memory
3. Try to deploy it

Actual results:
Nova won't be able to allocate the amount of ram asked and will fail with a "no valid host found"


Expected results:
The node should be picked for deployment

Additional info:
Comment 5 errata-xmlrpc 2016-04-07 17:41:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.