Bug 1274820 - python depends on python-pip
python depends on python-pip
Status: CLOSED DUPLICATE of bug 1279957
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Charalampos Stratakis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 11:06 EDT by Attila Fazekas
Modified: 2016-01-29 08:31 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 08:30:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Fazekas 2015-10-23 11:06:18 EDT
Description of problem:

python-2.7.10-8.fc23.x86_64 depends on python-pip.

I do not see why pip would be strong run time dependency for python,
for example it works after rpm -ql python-pip | sudo xargs rm.
Comment 1 Fedora Admin XMLRPC Client 2016-01-29 08:05:36 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Petr Viktorin 2016-01-29 08:30:13 EST

*** This bug has been marked as a duplicate of bug 1279957 ***
Comment 3 Petr Viktorin 2016-01-29 08:31:05 EST
Removing pip would break the "ensurepip" package, which is now in Python's standard library: https://docs.python.org/2/library/ensurepip.html

Note You need to log in before you can comment on or make changes to this bug.