Bug 1274849 - Don't warn about nonexisting connection drivers
Don't warn about nonexisting connection drivers
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 12:10 EDT by Christian Stadelmann
Modified: 2016-04-08 16:23 EDT (History)
10 users (show)

See Also:
Fixed In Version: libvirt-1.2.13.2-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-08 16:23:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-10-23 12:10:11 EDT
Version-Release number of selected component (if applicable):
libvirt-daemon-1.2.13.1-3.fc22.x86_64

How reproducible:
always

Steps to Reproduce:
1. install libvirt with some but not all connection drivers
2. reboot
3. watch syslog

Actual results:
You'll see entries like these:
Module /usr/lib64/libvirt/connection-driver/libvirt_driver_libxl.so not accessible
Module /usr/lib64/libvirt/connection-driver/libvirt_driver_lxc.so not accessible
Module /usr/lib64/libvirt/connection-driver/libvirt_driver_uml.so not accessible
Module /usr/lib64/libvirt/connection-driver/libvirt_driver_vbox.so not accessible

Expected results:
No warnings. I didn't install those drivers. Libvirt doesn't depend on these, so it should not warn.

Additional info:
This issue is present since libvirt 1.2.13.1-2.fc22 at least.
Comment 1 Cole Robinson 2015-10-23 13:24:45 EDT
Still in libvirt.git. We should make it VIR_INFO or VIR_DEBUG IMO


$ git grep --context=10 -n "Module %s not"
src/driver.c-55-
src/driver.c-56-    if (!(modfile = virFileFindResourceFull(name,
src/driver.c-57-                                            "libvirt_driver_",
src/driver.c-58-                                            ".so",
src/driver.c-59-                                            abs_topbuilddir "/src/.libs",
src/driver.c-60-                                            DEFAULT_DRIVER_DIR,
src/driver.c-61-                                            "LIBVIRT_DRIVER_DIR")))
src/driver.c-62-        return NULL;
src/driver.c-63-
src/driver.c-64-    if (access(modfile, R_OK) < 0) {
src/driver.c:65:        VIR_WARN("Module %s not accessible", modfile);
src/driver.c-66-        goto cleanup;
src/driver.c-67-    }
src/driver.c-68-
src/driver.c-69-    virUpdateSelfLastChanged(modfile);
src/driver.c-70-
src/driver.c-71-    handle = dlopen(modfile, RTLD_NOW | RTLD_GLOBAL);
src/driver.c-72-    if (!handle) {
src/driver.c-73-        VIR_ERROR(_("failed to load module %s %s"), modfile, dlerror());
src/driver.c-74-        goto cleanup;
src/driver.c-75-    }
Comment 2 Fedora Update System 2016-03-17 18:08:53 EDT
libvirt-1.2.13.2-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8d287c777d
Comment 3 Fedora Update System 2016-03-18 19:54:14 EDT
libvirt-1.2.13.2-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8d287c777d
Comment 4 Fedora Update System 2016-04-08 16:22:55 EDT
libvirt-1.2.13.2-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.