Bug 1274869 - Two volume icons on KDE's panel after upgrade (F22->F23)
Two volume icons on KDE's panel after upgrade (F22->F23)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kmix (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
RejectedFreezeException
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 14:17 EDT by Giulio 'juliuxpigface'
Modified: 2015-11-04 15:53 EST (History)
11 users (show)

See Also:
Fixed In Version: kmix-15.08.2-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 15:53:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Plasma's session after upgrade (597.85 KB, image/png)
2015-10-23 14:17 EDT, Giulio 'juliuxpigface'
no flags Details
Plasma's session after upgrade (first volume icon) (583.39 KB, image/png)
2015-10-23 14:18 EDT, Giulio 'juliuxpigface'
no flags Details
Plasma's session after upgrade (second volume icon) (593.39 KB, image/png)
2015-10-23 14:19 EDT, Giulio 'juliuxpigface'
no flags Details

  None (edit)
Description Giulio 'juliuxpigface' 2015-10-23 14:17:44 EDT
Created attachment 1085879 [details]
Plasma's session after upgrade

Description of problem:
After the upgrade via dnf-system-upgrade, I find two (different) volume icons on Plasma's panel.

Version-Release number of selected component (if applicable):
plasma-workspace-5.4.2-4.fc23.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Update an installation of F22 (KDE spin)
2. Upgrade to F23 (# dnf system-upgrade download --releasever=23)
3. Login into KDE

Actual results:
There are two volume icons on the panel

Expected results:
Since I didn't add the supplementary icon, there should be only one icon related to the volume settings.

Additional info:
I'm testing with qemu-kvm
Comment 1 Giulio 'juliuxpigface' 2015-10-23 14:18 EDT
Created attachment 1085880 [details]
Plasma's session after upgrade (first volume icon)
Comment 2 Giulio 'juliuxpigface' 2015-10-23 14:19 EDT
Created attachment 1085881 [details]
Plasma's session after upgrade (second volume icon)
Comment 3 Rex Dieter 2015-10-23 14:44:53 EDT
Maybe we'll just have to document this in release notes.

plasma/kde-apps deliver 2 volume controls:  kmix and plasma-pa

Fedora 22 uses kmix by default

Fedora 23 uses plasma-pa by default

If you have both installed, they'll both show in the systray.


One other thing we could consider: on f23+, make kmix *not* show by default, and require a user to run and opt-in (triaging to kmix)
Comment 4 Fedora Blocker Bugs Application 2015-10-23 14:49:18 EDT
Proposed as a Freeze Exception for 23-final by Fedora user juliuxpigface using the blocker tracking app because:

 Please note that there are some criteria which are partially unmet because of this bug:
- 2.4.7 Default panel functionality (The key question is "would this bug cause significant inconvenience or just a really bad first impression to a typical user or reviewer of the release?" )
- 2.4 Upgrade requirements ("The upgraded system must meet all release criteria.")

To be honest, this does not seem a big issue to me. Yes, it might cause a bad impression on first users/reviewers, but doesn't seem to break a functionality and can be easily solved by an update. t's certainly worth a discussion, anyway. That's why I propose it as FE.

References:
- https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#Default_panel_functionality
-https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria#Upgrade_requirements
Comment 5 Rex Dieter 2015-10-23 14:55:08 EDT
Offhand, I'm -1

This can be fixed easily enough (if at all), by subsequent updates
Comment 6 Rex Dieter 2015-10-23 15:21:31 EDT
anyone willing to help contribute a release notes snippet?  https://fedoraproject.org/wiki/Release_notes_process


else, I'll just work on a kmix update to disable autostart (by default) on f23+ as threatened
Comment 8 Fedora Update System 2015-10-24 08:51:28 EDT
kmix-15.08.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-a00b170f97
Comment 9 Petr Schindler 2015-10-26 13:32:50 EDT
Discussed at 2015-10-26 blocker review meeting: [1]. 

This bug was rejected as FreezeException: This bug can be fixed via updates and is not severe enough to break freeze for it.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2015-10-26/f23-blocker-review.2015-10-26-16.00.html
Comment 10 Fedora Update System 2015-10-26 22:19:53 EDT
kmix-15.08.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kmix'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-a00b170f97
Comment 11 Fedora Update System 2015-11-04 15:53:47 EST
kmix-15.08.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.