Bug 1274901 - rhel-osp-director: rhel7.2 - overcloud deployment fails : Error running /var/lib/heat-config/heat-config-puppet/8941cb58-512c-4300-a412-e060aceeedeb.pp on controller.
rhel-osp-director: rhel7.2 - overcloud deployment fails : Error running /var/...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity high
: y2
: 7.0 (Kilo)
Assigned To: chris alfonso
Alexander Chuzhoy
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 15:30 EDT by Alexander Chuzhoy
Modified: 2016-01-31 21:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:57:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages from compute (31.12 KB, application/x-gzip)
2015-10-23 15:33 EDT, Alexander Chuzhoy
no flags Details
/var/log/messages from controller (32.60 KB, application/x-gzip)
2015-10-23 15:33 EDT, Alexander Chuzhoy
no flags Details

  None (edit)
Description Alexander Chuzhoy 2015-10-23 15:30:05 EDT
rhel-osp-director: overcloud deployment fails : Error running /var/lib/heat-config/heat-config-puppet/8941cb58-512c-4300-a412-e060aceeedeb.pp on controller.


Environment:

openstack-puppet-modules-2015.1.8-21.el7ost.noarch
instack-undercloud-2.1.2-31.el7ost.noarch
openstack-heat-common-2015.1.1-6.el7ost.noarch

Steps to reproduce:

Attempt to deploy the overcloud with:
openstack overcloud deploy --templates



Result:

The deployment fails:
Stack failed with status: Resource CREATE failed: Error: resources.ComputeNodesPostDeployment.resources.ComputePuppetDeployment.resources[0]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 1     



Checking the /var/log/messages on nodes:



 Invalid resource type package_manifest at /var/lib/heat-config/heat-config-puppet/8941cb58-512c-4300-a412-e060aceeedeb.pp:1608 on node overcloud-controller-0.localdomain\nWrapped exception:\nInvalid resource type
 package_manifest\u001b[0m\n\u001b[1;31mError: Puppet::Parser::AST::Resource failed with error ArgumentError: Invalid resource type package_manifest at /var/lib/heat-config/heat-config-puppet/8941cb58-512c-4300-a4
12-e060aceeedeb.pp:1608 on node overcloud-controller-0.localdomain\u001b[0m\n", "deploy_status_code": 1}
Oct 23 15:20:04 localhost os-collect-config: [2015-10-23 15:20:04,515] (heat-config) [DEBUG] [2015-10-23 15:19:58,071] (heat-config) [DEBUG] Running FACTER_heat_outputs_path="/var/run/heat-config/heat-config-puppe
t/8941cb58-512c-4300-a412-e060aceeedeb"  FACTER_fqdn="overcloud-controller-0.localdomain"  FACTER_deploy_config_name="overcloud-ControllerNodesPostDeployment-zwxrmeayvf3i-ControllerPuppetConfig-dpqmjao4cmvq-Contro
llerPuppetConfigImpl-b76ie233djeu"  puppet apply --detailed-exitcodes /var/lib/heat-config/heat-config-puppet/8941cb58-512c-4300-a412-e060aceeedeb.pp
Oct 23 15:20:04 localhost os-collect-config: [2015-10-23 15:20:04,511] (heat-config) [INFO] Return code 1
Oct 23 15:20:04 localhost os-collect-config: [2015-10-23 15:20:04,511] (heat-config) [INFO] #033[1;31mError: Puppet::Parser::AST::Resource failed with error ArgumentError: Invalid resource type package_manifest at
 /var/lib/heat-config/heat-config-puppet/8941cb58-512c-4300-a412-e060aceeedeb.pp:1608 on node overcloud-controller-0.localdomain
Oct 23 15:20:04 localhost os-collect-config: Wrapped exception:
Oct 23 15:20:04 localhost os-collect-config: Invalid resource type package_manifest#033[0m
Oct 23 15:20:04 localhost os-collect-config: #033[1;31mError: Puppet::Parser::AST::Resource failed with error ArgumentError: Invalid resource type package_manifest at /var/lib/heat-config/heat-config-puppet/8941cb
58-512c-4300-a412-e060aceeedeb.pp:1608 on node overcloud-controller-0.localdomain#033[0m
Oct 23 15:20:04 localhost os-collect-config: [2015-10-23 15:20:04,511] (heat-config) [ERROR] Error running /var/lib/heat-config/heat-config-puppet/8941cb58-512c-4300-a412-e060aceeedeb.pp. [1]
Oct 23 15:20:04 localhost os-collect-config: [2015-10-23 15:20:04,515] (heat-config) [INFO] Completed /var/lib/heat-config/hooks/puppet
Comment 1 Alexander Chuzhoy 2015-10-23 15:33 EDT
Created attachment 1085893 [details]
/var/log/messages from compute
Comment 2 Alexander Chuzhoy 2015-10-23 15:33 EDT
Created attachment 1085894 [details]
/var/log/messages from controller
Comment 3 Alexander Chuzhoy 2015-11-02 11:45:52 EST
The error was also seen on rhel7.1
Comment 4 Mike Burns 2015-11-06 16:20:49 EST
I suspect this was fixed with a revert in OPM.  Marking Testonly
Comment 5 Alexander Chuzhoy 2015-11-26 13:45:33 EST
Verified:

Environment:
openstack-heat-engine-2015.1.2-2.el7ost.noarch
instack-undercloud-2.1.2-34.el7ost.noarch
openstack-heat-api-2015.1.2-2.el7ost.noarch
openstack-heat-common-2015.1.2-2.el7ost.noarch
openstack-heat-templates-0-0.7.20150605git.el7ost.noarch


Able to deploy overcloud.
Comment 7 errata-xmlrpc 2015-12-21 11:57:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.