This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1274903 - [abrt] evolution-data-server: gdata_service_update_entry(): evolution-calendar-factory-subprocess killed by SIGABRT
[abrt] evolution-data-server: gdata_service_update_entry(): evolution-calenda...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4876edc4db61479d24727065315...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 15:33 EDT by Justin W. Flory
Modified: 2015-10-27 03:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-27 03:46:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (31.59 KB, text/plain)
2015-10-23 15:34 EDT, Justin W. Flory
no flags Details
File: cgroup (190 bytes, text/plain)
2015-10-23 15:34 EDT, Justin W. Flory
no flags Details
File: core_backtrace (13.62 KB, text/plain)
2015-10-23 15:34 EDT, Justin W. Flory
no flags Details
File: dso_list (18.63 KB, text/plain)
2015-10-23 15:34 EDT, Justin W. Flory
no flags Details
File: environ (856 bytes, text/plain)
2015-10-23 15:34 EDT, Justin W. Flory
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-23 15:34 EDT, Justin W. Flory
no flags Details
File: maps (86.64 KB, text/plain)
2015-10-23 15:34 EDT, Justin W. Flory
no flags Details
File: mountinfo (3.47 KB, text/plain)
2015-10-23 15:34 EDT, Justin W. Flory
no flags Details
File: open_fds (848 bytes, text/plain)
2015-10-23 15:34 EDT, Justin W. Flory
no flags Details
File: proc_pid_status (1.00 KB, text/plain)
2015-10-23 15:34 EDT, Justin W. Flory
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 757169 None None None Never

  None (edit)
Description Justin W. Flory 2015-10-23 15:33:57 EDT
Description of problem:
I am unsure of how this crash happened - I do not use the Evolution mail or calendar client on this device.

Version-Release number of selected component:
evolution-data-server-3.18.1-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory-subprocess --factory gtasks --bus-name org.gnome.evolution.dataserver.Subprocess.Backend.Calendarx29618x5 --own-path /org/gnome/evolution/dataserver/Subprocess/Backend/Calendar/29618/5
crash_function: gdata_service_update_entry
executable:     /usr/libexec/evolution-calendar-factory-subprocess
global_pid:     30028
kernel:         4.2.3-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (6 frames)
 #4 gdata_service_update_entry at gdata/gdata-service.c:1661
 #5 gdata_tasks_service_update_task at gdata/services/tasks/gdata-tasks-service.c:781
 #6 ecb_gtasks_modify_objects at e-cal-backend-gtasks.c:1106
 #7 cal_backend_modify_objects_thread at e-cal-backend.c:2730
 #8 cal_backend_dispatch_thread at e-cal-backend.c:241
 #10 g_thread_proxy at gthread.c:778

Potential duplicate: bug 1246707
Comment 1 Justin W. Flory 2015-10-23 15:34:01 EDT
Created attachment 1085895 [details]
File: backtrace
Comment 2 Justin W. Flory 2015-10-23 15:34:02 EDT
Created attachment 1085896 [details]
File: cgroup
Comment 3 Justin W. Flory 2015-10-23 15:34:03 EDT
Created attachment 1085897 [details]
File: core_backtrace
Comment 4 Justin W. Flory 2015-10-23 15:34:04 EDT
Created attachment 1085898 [details]
File: dso_list
Comment 5 Justin W. Flory 2015-10-23 15:34:05 EDT
Created attachment 1085899 [details]
File: environ
Comment 6 Justin W. Flory 2015-10-23 15:34:07 EDT
Created attachment 1085900 [details]
File: limits
Comment 7 Justin W. Flory 2015-10-23 15:34:08 EDT
Created attachment 1085901 [details]
File: maps
Comment 8 Justin W. Flory 2015-10-23 15:34:09 EDT
Created attachment 1085902 [details]
File: mountinfo
Comment 9 Justin W. Flory 2015-10-23 15:34:10 EDT
Created attachment 1085903 [details]
File: open_fds
Comment 10 Justin W. Flory 2015-10-23 15:34:11 EDT
Created attachment 1085905 [details]
File: proc_pid_status
Comment 11 Milan Crha 2015-10-26 06:16:39 EDT
Thanks for a bug report. If I read the backtrace properly, then you've configured a GMail account in GNOME Online Accounts and what happened here is that you modified one task from the Google Tasks in some application different from the evolution. It doesn't matter much which client you used for this, the crash happened in the backend associated with the Google Tasks task list.

The crash happened due to an assertion in the libgdata library, file gdata/gdata-service.c:1661, function gdata_service_update_entry:
   assertion failed: (_link != NULL)

Why exactly this happened, or what data caused the crash, I do not see from the backtrace.

Do you recall what you modified in the Google Tasks task list, please?
Comment 12 Justin W. Flory 2015-10-26 14:45:59 EDT
(In reply to Milan Crha from comment #11)
> Thanks for a bug report. If I read the backtrace properly, then you've
> configured a GMail account in GNOME Online Accounts and what happened here
> is that you modified one task from the Google Tasks in some application
> different from the evolution. It doesn't matter much which client you used
> for this, the crash happened in the backend associated with the Google Tasks
> task list.
> 
> The crash happened due to an assertion in the libgdata library, file
> gdata/gdata-service.c:1661, function gdata_service_update_entry:
>    assertion failed: (_link != NULL)
> 
> Why exactly this happened, or what data caused the crash, I do not see from
> the backtrace.
> 
> Do you recall what you modified in the Google Tasks task list, please?

Actually, that would make sense. I do have the GNOME Tasks app installed with my Google account in the GNOME Online Accounts. If I recall correctly, I was doing very basic things, like adding tasks, removing tasks, changing due dates, etc. Every time I added or edited a task, the program gave me a nondescript error of "Error: Edit failed" or something along those lines, I can't remember verbatim.

I'm going to assume that those errors must have been related to this. However, it should be noted that the Tasks application itself did not crash on me - only adding and editing tasks seemed to cause the issue.

Oh, and as far as I know, the changes I made did actually save to Google.
Comment 13 Milan Crha 2015-10-27 03:46:06 EDT
Thanks for the update. I am able to reproduce it too, using gnome-todo package. I cannot reproduce it using Evolution. I'm moving this upstream [1], for better visibility. Please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=757169

Note You need to log in before you can comment on or make changes to this bug.